# CVE-2025-61668: @plone/volto vulnerable to potential DoS by invoking specific URL by anonymous user

> An anonymous user can crash the Volto NodeJS server by visiting a specific URL, causing a denial of service.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Oct 2025
- **Updated:** 3 Oct 2025
- **Also known as:** GHSA-m8rj-ppph-mj33

## What is CVE-2025-61668?

CVE-2025-61668 is a high-severity denial of service vulnerability in plone volto, published on 2 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Volto is a ReactJS-based frontend for the Plone Content Management System. Versions 16.34.0 and below, 17.0.0 through 17.22.1, 18.0.0 through 18.27.1, and 19.0.0-alpha.1 through 19.0.0-alpha.5, an anonymous user could cause the NodeJS server part of Volto to quit with an error when visiting a specific URL. This issue is fixed in versions 16.34.1, 17.22.2, 18.27.2 and 19.0.0-alpha.6.

Weakness: CWE-754 (Improper Check for Unusual or Exceptional Conditions), CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2025-61668?

8 open source packages ship an affected version, including @plone/volto.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@plone/volto` | npm | All versions | 16.34.1 |
| `@plone/volto` | npm | All versions | 16.34.1 |
| `@plone/volto` | npm | From 17.0.0 | 17.22.2 |
| `@plone/volto` | npm | From 17.0.0 | 17.22.2 |
| `@plone/volto` | npm | From 18.0.0 | 18.27.2 |
| `@plone/volto` | npm | From 18.0.0 | 18.27.2 |
| `@plone/volto` | npm | From 19.0.0-alpha.1 | 19.0.0-alpha.6 |
| `@plone/volto` | npm | From 19.0.0-alpha.1 | 19.0.0-alpha.6 |

## How do I fix CVE-2025-61668?

Upgrade @plone/volto to a fixed version for your release line: 16.34.1, 17.22.2, 18.27.2 or 19.0.0-alpha.6.

## Is CVE-2025-61668 being exploited?

There is no known exploitation of CVE-2025-61668 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-61668 and fix it if it is affected.

What it is: CVE-2025-61668 is a high-severity denial of service vulnerability in plone volto, published on 2 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-61668 in the wild and no public exploit code.

Affected packages and fixed versions:
- @plone/volto (npm): affected all versions; fixed in 16.34.1
- @plone/volto (npm): affected all versions; fixed in 16.34.1
- @plone/volto (npm): affected from 17.0.0; fixed in 17.22.2
- @plone/volto (npm): affected from 17.0.0; fixed in 17.22.2
- @plone/volto (npm): affected from 18.0.0; fixed in 18.27.2
- @plone/volto (npm): affected from 18.0.0; fixed in 18.27.2
- @plone/volto (npm): affected from 19.0.0-alpha.1; fixed in 19.0.0-alpha.6
- @plone/volto (npm): affected from 19.0.0-alpha.1; fixed in 19.0.0-alpha.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-61668/ (Markdown: https://insights.sbomify.com/CVE-2025-61668/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-61668
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-61668
- OSV: https://osv.dev/vulnerability/CVE-2025-61668

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-61668/
Summaries are generated and may contain mistakes; the official description above is the record.
