# CVE-2025-61669: jupyter_server next parameter open redirect can redirect users to external domains

> Attackers can redirect users to malicious external domains via the login next parameter, facilitating phishing attacks against Jupyter Server users.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 May 2026
- **Updated:** 5 May 2026
- **Also known as:** CLEANSTART-2026-JD56309, CLEANSTART-2026-ZJ86247, DEBIAN-CVE-2025-61669, GHSA-qh7q-6qm3-653w, PYSEC-2026-67, UBUNTU-CVE-2025-61669

## What is CVE-2025-61669?

CVE-2025-61669 is a medium-severity vulnerability in jupyter-server jupyter_server, published on 5 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Jupyter Server is the backend for Jupyter web applications. In jupyter_server versions through 2.17.0, the next query parameter in the login flow is insufficiently validated in `LoginFormHandler._redirect_safe()`, which allows redirects to arbitrary external domains via values such as `///example.com`. An attacker can use a crafted login URL to redirect users to a malicious site and facilitate phishing attacks. This issue is fixed in version 2.18.0.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2025-61669?

3 open source packages ship an affected version, including jupyter-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jupyter-server` | PyPI | All versions | 2.18.0 |
| `jupyter-server` | PyPI | All versions | 2.18.0 |
| `jupyter-server` | PyPI | All versions | 2.18.0 |

Products: Jupyter Jupyter Server.

## How do I fix CVE-2025-61669?

Upgrade jupyter-server to 2.18.0 or later.

## Is CVE-2025-61669 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-61669 exists.

## Other vulnerabilities in jupyter-server jupyter_server

- [CVE-2026-44727](https://insights.sbomify.com/CVE-2026-44727/): Jupyter Server: Stored XSS in `NbconvertFileHandler` / `NbconvertPostHandler` via missing `sandbox` CSP (critical 9.3)
- [CVE-2026-35397](https://insights.sbomify.com/CVE-2026-35397/): jupyter-server path traversal allows access to sibling directories sharing root_dir name prefix (high 7.6)
- [CVE-2026-40110](https://insights.sbomify.com/CVE-2026-40110/): jupyter-server CORS origin validation bypass via unanchored regex in allow_origin_pat (high 7.6)
- [CVE-2026-40934](https://insights.sbomify.com/CVE-2026-40934/): jupyter-server authentication cookies remain valid after password reset due to static cookie secret (high 7.6)
- [CVE-2024-35178](https://insights.sbomify.com/CVE-2024-35178/): Jupyter server on Windows discloses Windows user password hash (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-61669 and fix it if it is affected.

What it is: CVE-2025-61669 is a medium-severity vulnerability in jupyter-server jupyter_server, published on 5 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-61669 exists.

Affected packages and fixed versions:
- jupyter-server (PyPI): affected all versions; fixed in 2.18.0
- jupyter-server (PyPI): affected all versions; fixed in 2.18.0
- jupyter-server (PyPI): affected all versions; fixed in 2.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-61669/ (Markdown: https://insights.sbomify.com/CVE-2025-61669/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-61669
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-61669
- OSV: https://osv.dev/vulnerability/CVE-2025-61669

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-61669/
Summaries are generated and may contain mistakes; the official description above is the record.
