{"answers":{"affected":"3 open source packages ship an affected version, including python-a2a. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6167 exists.","fix":"Upgrade python-a2a to 0.5.6 or later.","what":"CVE-2025-6167 is a medium-severity path traversal vulnerability in themanojdesai python-a2a, published on 17 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-6167 and fix it if it is affected.\n\nWhat it is: CVE-2025-6167 is a medium-severity path traversal vulnerability in themanojdesai python-a2a, published on 17 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6167 exists.\n\nAffected packages and fixed versions:\n- python-a2a (PyPI): affected all versions; fixed in 0.5.6\n- python-a2a (PyPI): affected all versions; fixed in 0.5.6\n- python-a2a (PyPI): affected all versions; fixed in 0.5.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-6167/ (Markdown: https://insights.sbomify.com/CVE-2025-6167/index.md)","id":"CVE-2025-6167","markdown":"https://insights.sbomify.com/CVE-2025-6167/index.md","name":"CVE-2025-6167","record":{"aliases":["GHSA-rp38-pj7h-r8q2","PYSEC-2025-64"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python A2A library","requires_auth":"low_privilege","summary":"An attacker can exploit a path traversal vulnerability in the python-a2a library to read or modify arbitrary files on the server.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"python_a2a","vendor":"themanojdesai"}],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:A/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X","version":"4.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"A vulnerability classified as critical has been found in themanojdesai python-a2a up to 0.5.5. Affected is the function create_workflow of the file python_a2a/agent_flow/server/api.py. The manipulation leads to path traversal. Upgrading to version 0.5.6 is able to address this issue. It is recommended to upgrade the affected component.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"themanojdesai python-a2a api.py create_workflow path traversal","id":"CVE-2025-6167","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2025"},"n_packages":3,"n_references":6,"next":{"headline":"Incorrect Authorization in GitLab","id":"CVE-2025-6168"},"packages":[{"ecosystem":"PyPI","fixed":["0.5.6"],"introduced":["0"],"last_affected":[],"package":"python-a2a","purl":null,"source":"GHSA-rp38-pj7h-r8q2"},{"ecosystem":"PyPI","fixed":["0.5.6"],"introduced":["0"],"last_affected":[],"package":"python-a2a","purl":"pkg:pypi/python-a2a","source":"GHSA-rp38-pj7h-r8q2"},{"ecosystem":"PyPI","fixed":["0.5.6"],"introduced":["0"],"last_affected":[],"package":"python-a2a","purl":"pkg:pypi/python-a2a","source":"PYSEC-2025-64"}],"prev":{"headline":"frdel Agent-Zero image_get.py image_get path traversal","id":"CVE-2025-6166"},"products":["python-a2a"],"published":"2025-06-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-17","vendors":["themanojdesai"]},"summary":"An attacker can exploit a path traversal vulnerability in the python-a2a library to read or modify arbitrary files on the server.","url":"https://insights.sbomify.com/CVE-2025-6167/"}