# CVE-2025-6167: themanojdesai python-a2a api.py create_workflow path traversal

> An attacker can exploit a path traversal vulnerability in the python-a2a library to read or modify arbitrary files on the server.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:A/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jun 2025
- **Updated:** 17 Jun 2025
- **Also known as:** GHSA-rp38-pj7h-r8q2, PYSEC-2025-64

## What is CVE-2025-6167?

CVE-2025-6167 is a medium-severity path traversal vulnerability in themanojdesai python-a2a, published on 17 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability classified as critical has been found in themanojdesai python-a2a up to 0.5.5. Affected is the function create_workflow of the file python_a2a/agent_flow/server/api.py. The manipulation leads to path traversal. Upgrading to version 0.5.6 is able to address this issue. It is recommended to upgrade the affected component.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-6167?

3 open source packages ship an affected version, including python-a2a. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `python-a2a` | PyPI | All versions | 0.5.6 |
| `python-a2a` | PyPI | All versions | 0.5.6 |
| `python-a2a` | PyPI | All versions | 0.5.6 |

Products: Themanojdesai Python A2a.

## How do I fix CVE-2025-6167?

Upgrade python-a2a to 0.5.6 or later.

## Is CVE-2025-6167 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6167 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-6167 and fix it if it is affected.

What it is: CVE-2025-6167 is a medium-severity path traversal vulnerability in themanojdesai python-a2a, published on 17 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6167 exists.

Affected packages and fixed versions:
- python-a2a (PyPI): affected all versions; fixed in 0.5.6
- python-a2a (PyPI): affected all versions; fixed in 0.5.6
- python-a2a (PyPI): affected all versions; fixed in 0.5.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-6167/ (Markdown: https://insights.sbomify.com/CVE-2025-6167/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-6167
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-6167
- OSV: https://osv.dev/vulnerability/CVE-2025-6167

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-6167/
Summaries are generated and may contain mistakes; the official description above is the record.
