CVE-2025-61672 Synapse: Invalid device keys degrade federation functionality
An attacker can degrade federation functionality by submitting invalid device keys, breaking outbound connections to other homeservers.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-61672?
CVE-2025-61672 is a medium-severity denial of service vulnerability in element-hq synapse, published on 8 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Synapse is an open source Matrix homeserver implementation. Lack of validation for device keys in Synapse before 1.138.3 and in Synapse 1.139.0 allow an attacker registered on the victim homeserver to degrade federation functionality, unpredictably breaking outbound federation to other homeservers. The issue is patched in Synapse 1.138.3, 1.138.4, 1.139.1, and 1.139.2. Note that even though 1.138.3 and 1.139.1 fix the vulnerability, they inadvertently introduced an unrelated regression. For this reason, the maintainers of Synapse recommend skipping these releases and upgrading straight to 1.138.4 and 1.139.2.
Weakness: CWE-1287
Which versions are affected by CVE-2025-61672?
5 open source packages ship an affected version, including matrix-synapse.
| Package | Affected | Fixed in |
|---|---|---|
matrix-synapse PyPI | All versions | 1.138.3, 1.139.1 |
matrix-synapse PyPI | All versions | 1.138.3 |
matrix-synapse PyPI | All versions | 1.138.3 |
matrix-synapse PyPI | From 1.139.0rc2 | 1.139.1 |
matrix-synapse PyPI | From 1.139.0rc2 | 1.139.1 |
Linux distribution packages (1)
matrix-synapse openSUSE:Tumbleweed | All versions | 1.139.1-1.1 |
How do I fix CVE-2025-61672?
Upgrade matrix-synapse to a fixed version for your release line: 1.138.3 or 1.139.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-61672 being exploited?
There is no known exploitation of CVE-2025-61672 in the wild and no public exploit code.
Sources
Also known as GHSA-fh66-fcv5-jjfr, PYSEC-2026-1612, UBUNTU-CVE-2025-61672, openSUSE-SU-2025:15603-1.