{"answers":{"affected":"5 open source packages ship an affected version, including matrix-synapse.","exploited":"There is no known exploitation of CVE-2025-61672 in the wild and no public exploit code.","fix":"Upgrade matrix-synapse to a fixed version for your release line: 1.138.3 or 1.139.1.","what":"CVE-2025-61672 is a medium-severity denial of service vulnerability in element-hq synapse, published on 8 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-61672 and fix it if it is affected.\n\nWhat it is: CVE-2025-61672 is a medium-severity denial of service vulnerability in element-hq synapse, published on 8 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-61672 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- matrix-synapse (PyPI): affected all versions; fixed in 1.138.3, 1.139.1\n- matrix-synapse (PyPI): affected all versions; fixed in 1.138.3\n- matrix-synapse (PyPI): affected all versions; fixed in 1.138.3\n- matrix-synapse (PyPI): affected from 1.139.0rc2; fixed in 1.139.1\n- matrix-synapse (PyPI): affected from 1.139.0rc2; fixed in 1.139.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-61672/ (Markdown: https://insights.sbomify.com/CVE-2025-61672/index.md)","id":"CVE-2025-61672","markdown":"https://insights.sbomify.com/CVE-2025-61672/index.md","name":"CVE-2025-61672","record":{"aliases":["GHSA-fh66-fcv5-jjfr","PYSEC-2026-1612","UBUNTU-CVE-2025-61672","openSUSE-SU-2025:15603-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Matrix homeserver","requires_auth":"low_privilege","summary":"An attacker can degrade federation functionality by submitting invalid device keys, breaking outbound connections to other homeservers.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-1287","name":"Improper Validation of Specified Type of Input"}],"description":"Synapse is an open source Matrix homeserver implementation. Lack of validation for device keys in Synapse before 1.138.3 and in Synapse 1.139.0 allow an attacker registered on the victim homeserver to degrade federation functionality, unpredictably breaking outbound federation to other homeservers. The issue is patched in Synapse 1.138.3, 1.138.4, 1.139.1, and 1.139.2. Note that even though 1.138.3 and 1.139.1 fix the vulnerability, they inadvertently introduced an unrelated regression. For this reason, the maintainers of Synapse recommend skipping these releases and upgrading straight to 1.138.4 and 1.139.2.","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Synapse: Invalid device keys degrade federation functionality","id":"CVE-2025-61672","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":6,"n_references":6,"next":{"headline":"Karapace is vulnerable to Authentication Bypass","id":"CVE-2025-61673"},"packages":[{"ecosystem":"PyPI","fixed":["1.138.3","1.139.1"],"introduced":["0","1.139.0rc2"],"last_affected":[],"package":"matrix-synapse","purl":"pkg:pypi/matrix-synapse","source":"PYSEC-2026-1612"},{"ecosystem":"PyPI","fixed":["1.138.3"],"introduced":["0"],"last_affected":[],"package":"matrix-synapse","purl":null,"source":"GHSA-fh66-fcv5-jjfr"},{"ecosystem":"PyPI","fixed":["1.138.3"],"introduced":["0"],"last_affected":[],"package":"matrix-synapse","purl":"pkg:pypi/matrix-synapse","source":"GHSA-fh66-fcv5-jjfr"},{"ecosystem":"PyPI","fixed":["1.139.1"],"introduced":["1.139.0rc2"],"last_affected":[],"package":"matrix-synapse","purl":null,"source":"GHSA-fh66-fcv5-jjfr"},{"ecosystem":"PyPI","fixed":["1.139.1"],"introduced":["1.139.0rc2"],"last_affected":[],"package":"matrix-synapse","purl":"pkg:pypi/matrix-synapse","source":"GHSA-fh66-fcv5-jjfr"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.139.1-1.1"],"introduced":["0"],"last_affected":[],"package":"matrix-synapse","purl":"pkg:rpm/opensuse/matrix-synapse\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15603-1"}],"prev":{"headline":"Further research determined the issue is not an open source vulnerability.","id":"CVE-2025-61671"},"products":["synapse"],"published":"2025-10-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-15","vendors":["element-hq"]},"summary":"An attacker can degrade federation functionality by submitting invalid device keys, breaking outbound connections to other homeservers.","url":"https://insights.sbomify.com/CVE-2025-61672/"}