# CVE-2025-61676: October CMS Vulnerable to Stored XSS via Branding Styles

> Attackers with backend style permissions can inject malicious scripts into branding settings, leading to arbitrary code execution for all backend users.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Jan 2026
- **Updated:** 12 Jan 2026
- **Also known as:** GHSA-wvpq-h33f-8rp6

## What is CVE-2025-61676?

CVE-2025-61676 is a medium-severity cross-site scripting vulnerability in Octobercms October, published on 10 Jan 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

October is a Content Management System (CMS) and web platform. Prior to versions 3.7.13 and 4.0.12, a cross-site scripting (XSS) vulnerabilities was identified in October CMS backend configuration forms. A user with the Customize Backend Styles permission could inject malicious HTML/JS into the stylesheet input at Styles from Branding & Appearance settings. A specially crafted input could break out of the intended <style> context, allowing arbitrary script execution across backend pages for all users. This issue has been patched in versions 3.7.13 and 4.0.12.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-61676?

4 open source packages ship an affected version, including october/system. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `october/system` | Packagist | All versions | 3.7.13 |
| `october/system` | Packagist | All versions | 3.7.13 |
| `october/system` | Packagist | From 4.0.0 | 4.0.12 |
| `october/system` | Packagist | From 4.0.0 | 4.0.12 |

Products: Octobercms October.

## How do I fix CVE-2025-61676?

Upgrade october/system to a fixed version for your release line: 3.7.13 or 4.0.12.

## Is CVE-2025-61676 being exploited?

There is no known exploitation of CVE-2025-61676 in the wild and no public exploit code.

## Other vulnerabilities in Octobercms October

- [CVE-2021-32648](https://insights.sbomify.com/CVE-2021-32648/): October CMS Improper Authentication (high 8.2, exploited in the wild)
- [CVE-2021-3311](https://insights.sbomify.com/CVE-2021-3311/): October CMS Session ID not invalidated after logout (critical 9.8)
- [CVE-2017-1000194](https://insights.sbomify.com/CVE-2017-1000194/): October CMS File Upload Vulnerability (critical 9.8)
- [CVE-2017-1000196](https://insights.sbomify.com/CVE-2017-1000196/): Code injection in n/a (critical 9.8)
- [CVE-2017-1000197](https://insights.sbomify.com/CVE-2017-1000197/): Path traversal in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-61676 and fix it if it is affected.

What it is: CVE-2025-61676 is a medium-severity cross-site scripting vulnerability in Octobercms October, published on 10 Jan 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-61676 in the wild and no public exploit code.

Affected packages and fixed versions:
- october/system (Packagist): affected all versions; fixed in 3.7.13
- october/system (Packagist): affected all versions; fixed in 3.7.13
- october/system (Packagist): affected from 4.0.0; fixed in 4.0.12
- october/system (Packagist): affected from 4.0.0; fixed in 4.0.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-61676/ (Markdown: https://insights.sbomify.com/CVE-2025-61676/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-61676
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-61676
- OSV: https://osv.dev/vulnerability/CVE-2025-61676

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-61676/
Summaries are generated and may contain mistakes; the official description above is the record.
