CVE-2025-61677 DataChain: Deserialization of Untrusted Data from Environment Variables

Low 2.5 Published Updated

An attacker who can set specific environment variables can trigger arbitrary code execution in the DataChain library during application startup.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2025-61677?

CVE-2025-61677 is a low-severity unsafe deserialization vulnerability in iterative datachain, published on 3 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

DataChain is a Python-based AI-data warehouse for transforming and analyzing unstructured data. Versions 0.34.1 and below allow for deseriaization of untrusted data because of the way the DataChain library reads serialized objects from environment variables (such as DATACHAIN__METASTORE and DATACHAIN__WAREHOUSE) in the loader.py module. An attacker with the ability to set these environment variables can trigger code execution when the application loads. This issue is fixed in version 0.34.2.

Weakness: CWE-502

Which versions are affected by CVE-2025-61677?

3 open source packages ship an affected version, including datachain.

PackageAffectedFixed in
datachain PyPIAll versions0.34.2
datachain PyPIAll versions0.34.2
datachain PyPIAll versions0.34.2

How do I fix CVE-2025-61677?

Upgrade datachain to 0.34.2 or later.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2025-61677 being exploited?

There is no known exploitation of CVE-2025-61677 in the wild and no public exploit code.

Sources

Also known as GHSA-6px8-mr29-cj4r, PYSEC-2026-1288.

Is CVE-2025-61677 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free