{"answers":{"affected":"3 open source packages ship an affected version, including datachain.","exploited":"There is no known exploitation of CVE-2025-61677 in the wild and no public exploit code.","fix":"Upgrade datachain to 0.34.2 or later.","what":"CVE-2025-61677 is a low-severity unsafe deserialization vulnerability in iterative datachain, published on 3 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-61677 and fix it if it is affected.\n\nWhat it is: CVE-2025-61677 is a low-severity unsafe deserialization vulnerability in iterative datachain, published on 3 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-61677 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- datachain (PyPI): affected all versions; fixed in 0.34.2\n- datachain (PyPI): affected all versions; fixed in 0.34.2\n- datachain (PyPI): affected all versions; fixed in 0.34.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-61677/ (Markdown: https://insights.sbomify.com/CVE-2025-61677/index.md)","id":"CVE-2025-61677","markdown":"https://insights.sbomify.com/CVE-2025-61677/index.md","name":"CVE-2025-61677","record":{"aliases":["GHSA-6px8-mr29-cj4r","PYSEC-2026-1288"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python AI data warehouse","requires_auth":"low_privilege","summary":"An attacker who can set specific environment variables can trigger arbitrary code execution in the DataChain library during application startup.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":2.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"DataChain is a Python-based AI-data warehouse for transforming and analyzing unstructured data. Versions 0.34.1 and below allow for deseriaization of untrusted data because of the way the DataChain library reads serialized objects from environment variables (such as DATACHAIN__METASTORE and DATACHAIN__WAREHOUSE) in the loader.py module. An attacker with the ability to set these environment variables can trigger code execution when the application loads. This issue is fixed in version 0.34.2.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"DataChain: Deserialization of Untrusted Data from Environment Variables","id":"CVE-2025-61677","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2025"},"n_packages":3,"n_references":3,"next":{"headline":"FreePBX Endpoint Manager vulnerable to authenticated arbitrary file upload via fwbrand parameter","id":"CVE-2025-61678"},"packages":[{"ecosystem":"PyPI","fixed":["0.34.2"],"introduced":["0"],"last_affected":[],"package":"datachain","purl":null,"source":"GHSA-6px8-mr29-cj4r"},{"ecosystem":"PyPI","fixed":["0.34.2"],"introduced":["0"],"last_affected":[],"package":"datachain","purl":"pkg:pypi/datachain","source":"GHSA-6px8-mr29-cj4r"},{"ecosystem":"PyPI","fixed":["0.34.2"],"introduced":["0"],"last_affected":[],"package":"datachain","purl":"pkg:pypi/datachain","source":"PYSEC-2026-1288"}],"prev":{"headline":"October CMS Vulnerable to Stored XSS via Branding Styles","id":"CVE-2025-61676"},"products":["datachain"],"published":"2025-10-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-06","vendors":["iterative"]},"summary":"An attacker who can set specific environment variables can trigger arbitrary code execution in the DataChain library during application startup.","url":"https://insights.sbomify.com/CVE-2025-61677/"}