# CVE-2025-61678: FreePBX Endpoint Manager vulnerable to authenticated arbitrary file upload via fwbrand parameter

> Authenticated attackers can upload arbitrary files to attacker-controlled paths via the fwbrand parameter, potentially leading to remote code execution.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 14 Oct 2025
- **Updated:** 26 Feb 2026

## What is CVE-2025-61678?

CVE-2025-61678 is a high-severity vulnerability in FreePBX endpointman, published on 14 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

FreePBX Endpoint Manager is a module for managing telephony endpoints in FreePBX systems. In versions prior to 16.0.92 for FreePBX 16 and versions prior to 17.0.6 for FreePBX 17, the Endpoint Manager module contains an authenticated arbitrary file upload vulnerability affecting the fwbrand parameter. The fwbrand parameter allows an attacker to change the file path. Combined, these issues can result in a webshell being uploaded. Authentication with a known username is required to exploit this vulnerability. Successful exploitation allows authenticated users to upload arbitrary files to attacker-controlled paths on the server, potentially leading to remote code execution. This issue has been patched in version 16.0.92 for FreePBX 16 and version 17.0.6 for FreePBX 17.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2025-61678?


## How do I fix CVE-2025-61678?

No fix has been published for CVE-2025-61678 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-61678 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-61678 exists.

Public exploit code:

- FreePBX firmware file upload (metasploit)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-61678 and fix it if it is affected.

What it is: CVE-2025-61678 is a high-severity vulnerability in FreePBX endpointman, published on 14 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-61678 exists.

Affected product: FreePBX endpointman. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-61678/ (Markdown: https://insights.sbomify.com/CVE-2025-61678/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-61678
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-61678
- OSV: https://osv.dev/vulnerability/CVE-2025-61678

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-61678/
Summaries are generated and may contain mistakes; the official description above is the record.
