# CVE-2025-61679: Anyquery Unauthenticated Access Vulnerability Exposes Private Integration Data

> Attackers with local access can bypass authentication to read private integration data via the HTTP server.

- **Severity:** High 7.7 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 3 Oct 2025
- **Updated:** 6 Oct 2025
- **Also known as:** GHSA-5f7p-rhmq-hvc7

## What is CVE-2025-61679?

CVE-2025-61679 is a high-severity missing authorization vulnerability in julien040 anyquery, published on 3 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Anyquery is an SQL query engine built on top of SQLite. Versions 0.4.3 and below allow attackers who have already gained access to localhost, even with low privileges, to use the http server through the port unauthenticated, and access private integration data like emails, without any warning of a foreign login from the provider. This issue is fixed in version 0.4.4.

Weakness: CWE-287 (Improper Authentication), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-61679?


## How do I fix CVE-2025-61679?

No fix has been published for CVE-2025-61679 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-61679 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-61679 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-61679 and fix it if it is affected.

What it is: CVE-2025-61679 is a high-severity missing authorization vulnerability in julien040 anyquery, published on 3 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-61679 exists.

Affected product: julien040 anyquery. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-61679/ (Markdown: https://insights.sbomify.com/CVE-2025-61679/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-61679
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-61679
- OSV: https://osv.dev/vulnerability/CVE-2025-61679

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-61679/
Summaries are generated and may contain mistakes; the official description above is the record.
