# CVE-2025-61681: Kuno is Vulnerable to Stored XSS Attack via SVG File Upload

> Attackers can upload malicious SVG files to execute arbitrary JavaScript in victim browsers due to insufficient file validation in KUNO CMS.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 3 Oct 2025
- **Updated:** 6 Oct 2025
- **Also known as:** GHSA-q3w2-2vqp-gx3r

## What is CVE-2025-61681?

CVE-2025-61681 is a medium-severity cross-site scripting vulnerability in xuemian168 kuno, published on 3 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

KUNO CMS is a fully deployable full-stack blog application. Versions 1.3.13 and below contain validation flaws in its file upload functionality that can be exploited for stored XSS. The upload endpoint only validates file types based on Content-Type headers, lacks file content analysis and extension whitelist restrictions, allowing attackers to upload SVG files containing malicious scripts (disguised as images). When users access the uploaded resource pages, arbitrary JavaScript executes in their browsers. This issue is fixed in version 1.3.14.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2025-61681?


## How do I fix CVE-2025-61681?

No fix has been published for CVE-2025-61681 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-61681 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-61681 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-61681 and fix it if it is affected.

What it is: CVE-2025-61681 is a medium-severity cross-site scripting vulnerability in xuemian168 kuno, published on 3 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-61681 exists.

Affected product: xuemian168 kuno. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-61681/ (Markdown: https://insights.sbomify.com/CVE-2025-61681/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-61681
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-61681
- OSV: https://osv.dev/vulnerability/CVE-2025-61681

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-61681/
Summaries are generated and may contain mistakes; the official description above is the record.
