{"answers":{"affected":"2 open source packages ship an affected version, including mediawiki/semantic-media-wiki.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-61682 exists.","fix":"Upgrade mediawiki/semantic-media-wiki to 7.0.0 or later.","what":"CVE-2025-61682 is a high-severity cross-site scripting vulnerability in SemanticMediaWiki, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-61682 and fix it if it is affected.\n\nWhat it is: CVE-2025-61682 is a high-severity cross-site scripting vulnerability in SemanticMediaWiki, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-61682 exists.\n\nAffected packages and fixed versions:\n- mediawiki/semantic-media-wiki (Packagist): affected from 3.1.0; fixed in 7.0.0\n- mediawiki/semantic-media-wiki (Packagist): affected from 3.1.0; fixed in 7.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-61682/ (Markdown: https://insights.sbomify.com/CVE-2025-61682/index.md)","id":"CVE-2025-61682","markdown":"https://insights.sbomify.com/CVE-2025-61682/index.md","name":"CVE-2025-61682","record":{"aliases":["GHSA-hg8h-557g-q8pp"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"MediaWiki extension","requires_auth":"none","summary":"An attacker can inject malicious scripts via wikitext in Semantic MediaWiki, leading to stored XSS and potential code execution in victim browsers.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Semantic MediaWiki is a free, open-source extension to MediaWiki that lets users store and query data within the wiki's pages. Versions starting in 3.1.0 and prior to 7.0.0 insert the unsanitized value of a data attribute into the DOM as HTML, allowing for stored XSS through wikitext. Version 7.0.0 patches the issue.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Semantic MediaWiki vulnerable to stored XSS through wikitext via improper use of non-reserved data attributes","id":"CVE-2025-61682","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"Quicly has assertion failures","id":"CVE-2025-61684"},"packages":[{"ecosystem":"Packagist","fixed":["7.0.0"],"introduced":["3.1.0"],"last_affected":[],"package":"mediawiki/semantic-media-wiki","purl":null,"source":"GHSA-hg8h-557g-q8pp"},{"ecosystem":"Packagist","fixed":["7.0.0"],"introduced":["3.1.0"],"last_affected":[],"package":"mediawiki/semantic-media-wiki","purl":"pkg:composer/mediawiki/semantic-media-wiki","source":"GHSA-hg8h-557g-q8pp"}],"prev":{"headline":"Kuno is Vulnerable to Stored XSS Attack via SVG File Upload","id":"CVE-2025-61681"},"products":["SemanticMediaWiki"],"published":"2026-09-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-18","vendors":["SemanticMediaWiki"]},"summary":"An attacker can inject malicious scripts via wikitext in Semantic MediaWiki, leading to stored XSS and potential code execution in victim browsers.","url":"https://insights.sbomify.com/CVE-2025-61682/"}