# CVE-2025-61682: Semantic MediaWiki vulnerable to stored XSS through wikitext via improper use of non-reserved data attributes

> An attacker can inject malicious scripts via wikitext in Semantic MediaWiki, leading to stored XSS and potential code execution in victim browsers.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Sep 2026
- **Updated:** 18 Sep 2026
- **Also known as:** GHSA-hg8h-557g-q8pp

## What is CVE-2025-61682?

CVE-2025-61682 is a high-severity cross-site scripting vulnerability in SemanticMediaWiki, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Semantic MediaWiki is a free, open-source extension to MediaWiki that lets users store and query data within the wiki's pages. Versions starting in 3.1.0 and prior to 7.0.0 insert the unsanitized value of a data attribute into the DOM as HTML, allowing for stored XSS through wikitext. Version 7.0.0 patches the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-61682?

2 open source packages ship an affected version, including mediawiki/semantic-media-wiki.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki/semantic-media-wiki` | Packagist | From 3.1.0 | 7.0.0 |
| `mediawiki/semantic-media-wiki` | Packagist | From 3.1.0 | 7.0.0 |

## How do I fix CVE-2025-61682?

Upgrade mediawiki/semantic-media-wiki to 7.0.0 or later.

## Is CVE-2025-61682 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-61682 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-61682 and fix it if it is affected.

What it is: CVE-2025-61682 is a high-severity cross-site scripting vulnerability in SemanticMediaWiki, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-61682 exists.

Affected packages and fixed versions:
- mediawiki/semantic-media-wiki (Packagist): affected from 3.1.0; fixed in 7.0.0
- mediawiki/semantic-media-wiki (Packagist): affected from 3.1.0; fixed in 7.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-61682/ (Markdown: https://insights.sbomify.com/CVE-2025-61682/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-61682
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-61682
- OSV: https://osv.dev/vulnerability/CVE-2025-61682

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-61682/
Summaries are generated and may contain mistakes; the official description above is the record.
