# CVE-2025-61686: React Router has Path Traversal in File Session Storage

> Attackers can read or write files outside the session directory via path traversal in file session storage when using unsigned cookies.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jan 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-9583-h5hc-x8cw

## What is CVE-2025-61686?

CVE-2025-61686 is a critical path traversal vulnerability in remix-run react-router, published on 10 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

React Router is a router for React. In @react-router/node versions 7.0.0 through 7.9.3, @remix-run/deno prior to version 2.17.2, and @remix-run/node prior to version 2.17.2, if createFileSessionStorage() is being used from @react-router/node (or @remix-run/node/@remix-run/deno in Remix v2) with an unsigned cookie, it is possible for an attacker to cause the session to try to read/write from a location outside the specified session file directory. The success of the attack would depend on the permissions of the web server process to access those files. Read files cannot be returned directly to the attacker. Session file reads would only succeed if the file matched the expected session file format. If the file matched the session file format, the data would be populated into the server side session but not directly returned to the attacker unless the application logic returned specific session information. This issue has been patched in @react-router/node version 7.9.4, @remix-run/deno version 2.17.2, and @remix-run/node version 2.17.2.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-61686?

6 open source packages ship an affected version, including @react-router/node, @remix-run/deno and @remix-run/node. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@react-router/node` | npm | From 7.0.0 | 7.9.4 |
| `@react-router/node` | npm | From 7.0.0 | 7.9.4 |
| `@remix-run/deno` | npm | All versions | 2.17.2 |
| `@remix-run/deno` | npm | All versions | 2.17.2 |
| `@remix-run/node` | npm | All versions | 2.17.2 |
| `@remix-run/node` | npm | All versions | 2.17.2 |

Products: Shopify React-Router\/Node, Shopify Remix-Run\/Deno, Shopify Remix-Run\/Node.

## How do I fix CVE-2025-61686?

Upgrade @react-router/node to 7.9.4 or later.

## Is CVE-2025-61686 being exploited?

There is no known exploitation of CVE-2025-61686 in the wild and no public exploit code.

Public exploit code:

- CVE-2025-61686复现的dockerfile与poc (github_poc): https://github.com/FlowerWitch/CVE-2025-61686_docker
- https://github.com/Kai-One001/React-Router-CVE-2025-61686- (github_poc): https://github.com/Kai-One001/React-Router-CVE-2025-61686-
- React Router's createFileSessionStorage() in certain versions allows unsigned cookies to be manipulated, enabling file system access outside the session directory. (github_poc): https://github.com/boroeurnprach/CVE-2025-61686-PoC

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-61686 and fix it if it is affected.

What it is: CVE-2025-61686 is a critical path traversal vulnerability in remix-run react-router, published on 10 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-61686 in the wild and no public exploit code.

Affected packages and fixed versions:
- @react-router/node (npm): affected from 7.0.0; fixed in 7.9.4
- @react-router/node (npm): affected from 7.0.0; fixed in 7.9.4
- @remix-run/deno (npm): affected all versions; fixed in 2.17.2
- @remix-run/deno (npm): affected all versions; fixed in 2.17.2
- @remix-run/node (npm): affected all versions; fixed in 2.17.2
- @remix-run/node (npm): affected all versions; fixed in 2.17.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-61686/ (Markdown: https://insights.sbomify.com/CVE-2025-61686/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-61686
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-61686
- OSV: https://osv.dev/vulnerability/CVE-2025-61686

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-61686/
Summaries are generated and may contain mistakes; the official description above is the record.
