{"answers":{"affected":"2 open source packages ship an affected version, including flowise. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-61687 exists.","fix":"Upgrade flowise to 3.0.8 or later.","what":"CVE-2025-61687 is a high-severity vulnerability in Flowiseai Flowise, published on 6 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-61687 and fix it if it is affected.\n\nWhat it is: CVE-2025-61687 is a high-severity vulnerability in Flowiseai Flowise, published on 6 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-61687 exists.\n\nAffected packages and fixed versions:\n- flowise (npm): affected from 3.0.7; fixed in 3.0.8\n- flowise (npm): affected from 3.0.7; fixed in 3.0.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-61687/ (Markdown: https://insights.sbomify.com/CVE-2025-61687/index.md)","id":"CVE-2025-61687","markdown":"https://insights.sbomify.com/CVE-2025-61687/index.md","name":"CVE-2025-61687","record":{"aliases":["GHSA-35g6-rrw3-v6xc"],"analysis":{"component_type":"web_application","fix_type":"no_fix_stated","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"LLM flow builder","requires_auth":"low_privilege","summary":"Authenticated users can upload malicious Node.js web shells due to missing validation, potentially leading to remote code execution.","user_interaction":"not_required","vuln_class":"file_upload"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"flowise","vendor":"flowiseai"}],"cvss":{"score":8.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-434","name":"Unrestricted Upload of File with Dangerous Type"}],"description":"Flowise is a drag \u0026 drop user interface to build a customized large language model flow. A file upload vulnerability in version 3.0.7 of FlowiseAI allows authenticated users to upload arbitrary files without proper validation. This enables attackers to persistently store malicious Node.js web shells on the server, potentially leading to Remote Code Execution (RCE). The system fails to validate file extensions, MIME types, or file content during uploads. As a result, malicious scripts such as Node.js-based web shells can be uploaded and stored persistently on the server. These shells expose HTTP endpoints capable of executing arbitrary commands if triggered. The uploaded shell does not automatically execute, but its presence allows future exploitation via administrator error or chained vulnerabilities. This presents a high-severity threat to system integrity and confidentiality. As of time of publication, no known patched versions are available.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"FlowiseAI/Flosise has File Upload vulnerability","id":"CVE-2025-61687","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"flowiseai:flowise","products":["flowiseai:flowise"],"type":"file_upload","year":"2025"},"n_packages":2,"n_references":9,"next":{"headline":"Omni leaks information via the API","id":"CVE-2025-61688"},"packages":[{"ecosystem":"npm","fixed":["3.0.8"],"introduced":["3.0.7"],"last_affected":[],"package":"flowise","purl":null,"source":"GHSA-35g6-rrw3-v6xc"},{"ecosystem":"npm","fixed":["3.0.8"],"introduced":["3.0.7"],"last_affected":[],"package":"flowise","purl":"pkg:npm/flowise","source":"GHSA-35g6-rrw3-v6xc"}],"prev":{"headline":"React Router has Path Traversal in File Session Storage","id":"CVE-2025-61686"},"products":["Flowise"],"published":"2025-10-06","related":[{"cvss_score":10,"headline":"Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API","id":"CVE-2025-71338","kev_date_added":null,"published":"2026-06-25"},{"cvss_score":10,"headline":"Flowise: Authenticated RCE Via MCP Adapters","id":"CVE-2026-40933","kev_date_added":null,"published":"2026-04-21"},{"cvss_score":10,"headline":"Flowise is vulnerable to arbitrary file read, arbitrary file write","id":"CVE-2025-61913","kev_date_added":null,"published":"2025-10-08"},{"cvss_score":10,"headline":"Flowise has Remote Code Execution vulnerability","id":"CVE-2025-59528","kev_date_added":null,"published":"2025-09-22"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2026-52098","kev_date_added":null,"published":"2026-09-10"},{"cvss_score":9.8,"headline":"Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover","id":"CVE-2025-58434","kev_date_added":null,"published":"2025-09-12"},{"cvss_score":9.8,"headline":"Unsupervised OS command execution leads to remote code execution by unauthenticated network attackers","id":"CVE-2025-8943","kev_date_added":null,"published":"2025-08-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-06","vendors":["FlowiseAI"]},"summary":"Authenticated users can upload malicious Node.js web shells due to missing validation, potentially leading to remote code execution.","url":"https://insights.sbomify.com/CVE-2025-61687/"}