# CVE-2025-61687: FlowiseAI/Flosise has File Upload vulnerability

> Authenticated users can upload malicious Node.js web shells due to missing validation, potentially leading to remote code execution.

- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2025
- **Updated:** 6 Oct 2025
- **Also known as:** GHSA-35g6-rrw3-v6xc

## What is CVE-2025-61687?

CVE-2025-61687 is a high-severity vulnerability in Flowiseai Flowise, published on 6 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Flowise is a drag & drop user interface to build a customized large language model flow. A file upload vulnerability in version 3.0.7 of FlowiseAI allows authenticated users to upload arbitrary files without proper validation. This enables attackers to persistently store malicious Node.js web shells on the server, potentially leading to Remote Code Execution (RCE). The system fails to validate file extensions, MIME types, or file content during uploads. As a result, malicious scripts such as Node.js-based web shells can be uploaded and stored persistently on the server. These shells expose HTTP endpoints capable of executing arbitrary commands if triggered. The uploaded shell does not automatically execute, but its presence allows future exploitation via administrator error or chained vulnerabilities. This presents a high-severity threat to system integrity and confidentiality. As of time of publication, no known patched versions are available.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2025-61687?

2 open source packages ship an affected version, including flowise. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flowise` | npm | From 3.0.7 | 3.0.8 |
| `flowise` | npm | From 3.0.7 | 3.0.8 |

Products: Flowiseai Flowise.

## How do I fix CVE-2025-61687?

Upgrade flowise to 3.0.8 or later.

## Is CVE-2025-61687 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-61687 exists.

## Other vulnerabilities in Flowiseai Flowise

- [CVE-2025-71338](https://insights.sbomify.com/CVE-2025-71338/): Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API (critical 10.0)
- [CVE-2026-40933](https://insights.sbomify.com/CVE-2026-40933/): Flowise: Authenticated RCE Via MCP Adapters (critical 10.0)
- [CVE-2025-61913](https://insights.sbomify.com/CVE-2025-61913/): Flowise is vulnerable to arbitrary file read, arbitrary file write (critical 10.0)
- [CVE-2025-59528](https://insights.sbomify.com/CVE-2025-59528/): Flowise has Remote Code Execution vulnerability (critical 10.0)
- [CVE-2026-52098](https://insights.sbomify.com/CVE-2026-52098/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-61687 and fix it if it is affected.

What it is: CVE-2025-61687 is a high-severity vulnerability in Flowiseai Flowise, published on 6 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-61687 exists.

Affected packages and fixed versions:
- flowise (npm): affected from 3.0.7; fixed in 3.0.8
- flowise (npm): affected from 3.0.7; fixed in 3.0.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-61687/ (Markdown: https://insights.sbomify.com/CVE-2025-61687/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-61687
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-61687
- OSV: https://osv.dev/vulnerability/CVE-2025-61687

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-61687/
Summaries are generated and may contain mistakes; the official description above is the record.
