CVE-2025-61688 Omni leaks information via the API
Attackers can access sensitive information via the API in Omni, a Kubernetes management platform, requiring an upgrade to secure data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-61688?
CVE-2025-61688 is a high-severity vulnerability in siderolabs omni, published on 13 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Omni manages Kubernetes on bare metal, virtual machines, or in a cloud. Prior to 1.1.5 and 1.0.2, Omni might leak sensitive information via an API.
Weakness: CWE-200
Which versions are affected by CVE-2025-61688?
5 open source packages ship an affected version, including github.com/siderolabs/omni. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/siderolabs/omni Go | All versions | 1.0.2, 1.1.5 |
github.com/siderolabs/omni Go | All versions | 1.0.2 |
github.com/siderolabs/omni Go | All versions | 1.0.2 |
github.com/siderolabs/omni Go | From 1.1.0-beta.0 | 1.1.5 |
github.com/siderolabs/omni Go | From 1.1.0-beta.0 | 1.1.5 |
Products include Siderolabs Omni.
How do I fix CVE-2025-61688?
Upgrade github.com/siderolabs/omni to a fixed version for your release line: 1.0.2 or 1.1.5.
Is CVE-2025-61688 being exploited?
There is no known exploitation of CVE-2025-61688 in the wild and no public exploit code.
Other vulnerabilities in siderolabs omni
Sources
Also known as GHSA-77r9-w39m-9xh5, GO-2025-4022.