{"answers":{"affected":"5 open source packages ship an affected version, including github.com/siderolabs/omni. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-61688 in the wild and no public exploit code.","fix":"Upgrade github.com/siderolabs/omni to a fixed version for your release line: 1.0.2 or 1.1.5.","what":"CVE-2025-61688 is a high-severity vulnerability in siderolabs omni, published on 13 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-61688 and fix it if it is affected.\n\nWhat it is: CVE-2025-61688 is a high-severity vulnerability in siderolabs omni, published on 13 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-61688 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/siderolabs/omni (Go): affected all versions; fixed in 1.0.2, 1.1.5\n- github.com/siderolabs/omni (Go): affected all versions; fixed in 1.0.2\n- github.com/siderolabs/omni (Go): affected all versions; fixed in 1.0.2\n- github.com/siderolabs/omni (Go): affected from 1.1.0-beta.0; fixed in 1.1.5\n- github.com/siderolabs/omni (Go): affected from 1.1.0-beta.0; fixed in 1.1.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-61688/ (Markdown: https://insights.sbomify.com/CVE-2025-61688/index.md)","id":"CVE-2025-61688","markdown":"https://insights.sbomify.com/CVE-2025-61688/index.md","name":"CVE-2025-61688","record":{"aliases":["GHSA-77r9-w39m-9xh5","GO-2025-4022"],"analysis":{"component_type":"cloud_service","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Kubernetes management platform","requires_auth":"none","summary":"Attackers can access sensitive information via the API in Omni, a Kubernetes management platform, requiring an upgrade to secure data.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"omni","vendor":"siderolabs"}],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"Omni manages Kubernetes on bare metal, virtual machines, or in a cloud. Prior to 1.1.5 and 1.0.2, Omni might leak sensitive information via an API.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Omni leaks information via the API","id":"CVE-2025-61688","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"information_disclosure","year":"2025"},"n_packages":5,"n_references":1,"next":{"headline":"HTTP.jl vulnerable to Header injection/Response splitting via header construction.","id":"CVE-2025-61689"},"packages":[{"ecosystem":"Go","fixed":["1.0.2","1.1.5"],"introduced":["0","1.1.0-beta.0"],"last_affected":[],"package":"github.com/siderolabs/omni","purl":"pkg:golang/github.com/siderolabs/omni","source":"GO-2025-4022"},{"ecosystem":"Go","fixed":["1.0.2"],"introduced":["0"],"last_affected":[],"package":"github.com/siderolabs/omni","purl":null,"source":"GHSA-77r9-w39m-9xh5"},{"ecosystem":"Go","fixed":["1.0.2"],"introduced":["0"],"last_affected":[],"package":"github.com/siderolabs/omni","purl":"pkg:golang/github.com/siderolabs/omni","source":"GHSA-77r9-w39m-9xh5"},{"ecosystem":"Go","fixed":["1.1.5"],"introduced":["1.1.0-beta.0"],"last_affected":[],"package":"github.com/siderolabs/omni","purl":null,"source":"GHSA-77r9-w39m-9xh5"},{"ecosystem":"Go","fixed":["1.1.5"],"introduced":["1.1.0-beta.0"],"last_affected":[],"package":"github.com/siderolabs/omni","purl":"pkg:golang/github.com/siderolabs/omni","source":"GHSA-77r9-w39m-9xh5"}],"prev":{"headline":"FlowiseAI/Flosise has File Upload vulnerability","id":"CVE-2025-61687"},"products":["omni"],"published":"2025-10-13","related":[{"cvss_score":5.3,"headline":"Omni is Vulnerable to DoS via Empty Create/Update Resource Requests","id":"CVE-2025-59836","kev_date_added":null,"published":"2025-10-13"},{"cvss_score":0.5,"headline":"Omni Wireguard SideroLink potential escape","id":"CVE-2025-59824","kev_date_added":null,"published":"2025-09-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-14","vendors":["siderolabs"]},"summary":"Attackers can access sensitive information via the API in Omni, a Kubernetes management platform, requiring an upgrade to secure data.","url":"https://insights.sbomify.com/CVE-2025-61688/"}