CVE-2025-61733 Apache Kylin: Authentication bypass
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2025-61733?
CVE-2025-61733 is a high-severity vulnerability in Apache Kylin, published on 2 Oct 2025.
Official description
Authentication Bypass Using an Alternate Path or Channel vulnerability in Apache Kylin.
This issue affects Apache Kylin: from 4.0.0 through 5.0.2.
Users are recommended to upgrade to version 5.0.3, which fixes the issue.
Weakness: CWE-288
Which versions are affected by CVE-2025-61733?
4 open source packages ship an affected version, including org.apache.kylin:kylin and org.apache.kylin:kylin-core-common. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.kylin:kylin Maven | From 4.0.0 | 5.0.3 |
org.apache.kylin:kylin Maven | From 4.0.0 | 5.0.3 |
org.apache.kylin:kylin-core-common Maven | From 4.0.0 | 5.0.3 |
org.apache.kylin:kylin-core-common Maven | From 4.0.0 | 5.0.3 |
Products include Apache Kylin.
How do I fix CVE-2025-61733?
Upgrade org.apache.kylin:kylin to 5.0.3 or later.
Is CVE-2025-61733 being exploited?
There is no known exploitation of CVE-2025-61733 in the wild and no public exploit code.
Other vulnerabilities in Apache Kylin
- CVE-2020-1956 Apache Kylin OS Command Injection
- CVE-2026-62390 Apache Kylin: SQL Injection Vulnerability in Catalog Cache Refresh API
- CVE-2022-44621 Apache Kylin: Command injection by Diagnosis Controller
- CVE-2022-24697 Apache Kylin vulnerable to remote code execution
- CVE-2021-31522 Apache Kylin unsafe class loading
Sources
Also known as GHSA-mr9j-4j48-xcm2.