CVE-2025-61734 Apache Kylin: improper restriction of file read
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2025-61734?
CVE-2025-61734 is a high-severity vulnerability in Apache Kylin, published on 2 Oct 2025.
Official description
Files or Directories Accessible to External Parties vulnerability in Apache Kylin. You are fine as long as the Kylin's system and project admin access is well protected.
This issue affects Apache Kylin: from 4.0.0 through 5.0.2.
Users are recommended to upgrade to version 5.0.3, which fixes the issue.
Weakness: CWE-552
Which versions are affected by CVE-2025-61734?
14 open source packages ship an affected version, including org.apache.kylin:kylin, org.apache.kylin:kylin-common-server and org.apache.kylin:kylin-common-service. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.kylin:kylin Maven | From 4.0.0 | 5.0.3 |
org.apache.kylin:kylin Maven | From 4.0.0 | 5.0.3 |
org.apache.kylin:kylin-common-server Maven | From 4.0.0 | 5.0.3 |
org.apache.kylin:kylin-common-server Maven | From 4.0.0 | 5.0.3 |
org.apache.kylin:kylin-common-service Maven | From 4.0.0 | 5.0.3 |
org.apache.kylin:kylin-common-service Maven | From 4.0.0 | 5.0.3 |
8 more packages
org.apache.kylin:kylin-core-common Maven | From 4.0.0 | 5.0.3 |
org.apache.kylin:kylin-core-common Maven | From 4.0.0 | 5.0.3 |
org.apache.kylin:kylin-core-metadata Maven | From 4.0.0 | 5.0.3 |
org.apache.kylin:kylin-core-metadata Maven | From 4.0.0 | 5.0.3 |
org.apache.kylin:kylin-ops-server Maven | From 4.0.0 | 5.0.3 |
org.apache.kylin:kylin-ops-server Maven | From 4.0.0 | 5.0.3 |
org.apache.kylin:kylin-server Maven | From 4.0.0 | 5.0.3 |
org.apache.kylin:kylin-server Maven | From 4.0.0 | 5.0.3 |
Products include Apache Kylin.
How do I fix CVE-2025-61734?
Upgrade org.apache.kylin:kylin to 5.0.3 or later.
Is CVE-2025-61734 being exploited?
There is no known exploitation of CVE-2025-61734 in the wild and no public exploit code.
Other vulnerabilities in Apache Kylin
- CVE-2020-1956 Apache Kylin OS Command Injection
- CVE-2026-62390 Apache Kylin: SQL Injection Vulnerability in Catalog Cache Refresh API
- CVE-2022-44621 Apache Kylin: Command injection by Diagnosis Controller
- CVE-2022-24697 Apache Kylin vulnerable to remote code execution
- CVE-2021-31522 Apache Kylin unsafe class loading
Sources
Also known as GHSA-p86w-w5rh-m3hx.