# CVE-2025-61734: Apache Kylin: improper restriction of file read


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 2 Oct 2025
- **Updated:** 4 Nov 2025
- **Also known as:** GHSA-p86w-w5rh-m3hx

## What is CVE-2025-61734?

CVE-2025-61734 is a high-severity vulnerability in Apache Kylin, published on 2 Oct 2025. 

### Official description

Files or Directories Accessible to External Parties vulnerability in Apache Kylin.
 You are fine as long as the Kylin's system and project admin access is well protected.

This issue affects Apache Kylin: from 4.0.0 through 5.0.2.

Users are recommended to upgrade to version 5.0.3, which fixes the issue.

Weakness: CWE-552 (Files or Directories Accessible to External Parties)

## Which versions are affected by CVE-2025-61734?

14 open source packages ship an affected version, including org.apache.kylin:kylin, org.apache.kylin:kylin-common-server and org.apache.kylin:kylin-common-service. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.kylin:kylin` | Maven | From 4.0.0 | 5.0.3 |
| `org.apache.kylin:kylin` | Maven | From 4.0.0 | 5.0.3 |
| `org.apache.kylin:kylin-common-server` | Maven | From 4.0.0 | 5.0.3 |
| `org.apache.kylin:kylin-common-server` | Maven | From 4.0.0 | 5.0.3 |
| `org.apache.kylin:kylin-common-service` | Maven | From 4.0.0 | 5.0.3 |
| `org.apache.kylin:kylin-common-service` | Maven | From 4.0.0 | 5.0.3 |
| `org.apache.kylin:kylin-core-common` | Maven | From 4.0.0 | 5.0.3 |
| `org.apache.kylin:kylin-core-common` | Maven | From 4.0.0 | 5.0.3 |
| `org.apache.kylin:kylin-core-metadata` | Maven | From 4.0.0 | 5.0.3 |
| `org.apache.kylin:kylin-core-metadata` | Maven | From 4.0.0 | 5.0.3 |
| `org.apache.kylin:kylin-ops-server` | Maven | From 4.0.0 | 5.0.3 |
| `org.apache.kylin:kylin-ops-server` | Maven | From 4.0.0 | 5.0.3 |
| `org.apache.kylin:kylin-server` | Maven | From 4.0.0 | 5.0.3 |
| `org.apache.kylin:kylin-server` | Maven | From 4.0.0 | 5.0.3 |

Products: Apache Kylin.

## How do I fix CVE-2025-61734?

Upgrade org.apache.kylin:kylin to 5.0.3 or later.

## Is CVE-2025-61734 being exploited?

There is no known exploitation of CVE-2025-61734 in the wild and no public exploit code.

## Other vulnerabilities in Apache Kylin

- [CVE-2020-1956](https://insights.sbomify.com/CVE-2020-1956/): Apache Kylin OS Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-62390](https://insights.sbomify.com/CVE-2026-62390/): Apache Kylin: SQL Injection Vulnerability in Catalog Cache Refresh API (critical 9.8)
- [CVE-2022-44621](https://insights.sbomify.com/CVE-2022-44621/): Apache Kylin: Command injection by Diagnosis Controller (critical 9.8)
- [CVE-2022-24697](https://insights.sbomify.com/CVE-2022-24697/): Apache Kylin vulnerable to remote code execution (critical 9.8)
- [CVE-2021-31522](https://insights.sbomify.com/CVE-2021-31522/): Apache Kylin unsafe class loading (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-61734 and fix it if it is affected.

What it is: CVE-2025-61734 is a high-severity vulnerability in Apache Kylin, published on 2 Oct 2025. 
Exploitation: There is no known exploitation of CVE-2025-61734 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.kylin:kylin (Maven): affected from 4.0.0; fixed in 5.0.3
- org.apache.kylin:kylin (Maven): affected from 4.0.0; fixed in 5.0.3
- org.apache.kylin:kylin-common-server (Maven): affected from 4.0.0; fixed in 5.0.3
- org.apache.kylin:kylin-common-server (Maven): affected from 4.0.0; fixed in 5.0.3
- org.apache.kylin:kylin-common-service (Maven): affected from 4.0.0; fixed in 5.0.3
- org.apache.kylin:kylin-common-service (Maven): affected from 4.0.0; fixed in 5.0.3
- org.apache.kylin:kylin-core-common (Maven): affected from 4.0.0; fixed in 5.0.3
- org.apache.kylin:kylin-core-common (Maven): affected from 4.0.0; fixed in 5.0.3
- org.apache.kylin:kylin-core-metadata (Maven): affected from 4.0.0; fixed in 5.0.3
- org.apache.kylin:kylin-core-metadata (Maven): affected from 4.0.0; fixed in 5.0.3
- org.apache.kylin:kylin-ops-server (Maven): affected from 4.0.0; fixed in 5.0.3
- org.apache.kylin:kylin-ops-server (Maven): affected from 4.0.0; fixed in 5.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-61734/ (Markdown: https://insights.sbomify.com/CVE-2025-61734/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-61734
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-61734
- OSV: https://osv.dev/vulnerability/CVE-2025-61734

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-61734/
Summaries are generated and may contain mistakes; the official description above is the record.
