CVE-2025-61735 Apache Kylin: Server-Side Request Forgery
Attackers can exploit a Server-Side Request Forgery flaw in Apache Kylin to access internal resources if admin access is not properly protected.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-61735?
CVE-2025-61735 is a high-severity server-side request forgery vulnerability in Apache Kylin, published on 2 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Server-Side Request Forgery (SSRF) vulnerability in Apache Kylin.
This issue affects Apache Kylin: from 4.0.0 through 5.0.2. You are fine as long as the Kylin's system and project admin access is well protected.
Users are recommended to upgrade to version 5.0.3, which fixes the issue.
Weakness: CWE-918
Which versions are affected by CVE-2025-61735?
14 open source packages ship an affected version, including org.apache.kylin:kylin, org.apache.kylin:kylin-common-server and org.apache.kylin:kylin-common-service. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.kylin:kylin Maven | From 4.0.0 | 5.0.3 |
org.apache.kylin:kylin Maven | From 4.0.0 | 5.0.3 |
org.apache.kylin:kylin-common-server Maven | From 4.0.0 | 5.0.3 |
org.apache.kylin:kylin-common-server Maven | From 4.0.0 | 5.0.3 |
org.apache.kylin:kylin-common-service Maven | From 4.0.0 | 5.0.3 |
org.apache.kylin:kylin-common-service Maven | From 4.0.0 | 5.0.3 |
8 more packages
org.apache.kylin:kylin-core-common Maven | From 4.0.0 | 5.0.3 |
org.apache.kylin:kylin-core-common Maven | From 4.0.0 | 5.0.3 |
org.apache.kylin:kylin-core-metadata Maven | From 4.0.0 | 5.0.3 |
org.apache.kylin:kylin-core-metadata Maven | From 4.0.0 | 5.0.3 |
org.apache.kylin:kylin-ops-server Maven | From 4.0.0 | 5.0.3 |
org.apache.kylin:kylin-ops-server Maven | From 4.0.0 | 5.0.3 |
org.apache.kylin:kylin-server Maven | From 4.0.0 | 5.0.3 |
org.apache.kylin:kylin-server Maven | From 4.0.0 | 5.0.3 |
Products include Apache Kylin.
How do I fix CVE-2025-61735?
Upgrade org.apache.kylin:kylin to 5.0.3 or later.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2025-61735 being exploited?
There is no known exploitation of CVE-2025-61735 in the wild and no public exploit code.
Other vulnerabilities in Apache Kylin
- CVE-2020-1956 Apache Kylin OS Command Injection
- CVE-2026-62390 Apache Kylin: SQL Injection Vulnerability in Catalog Cache Refresh API
- CVE-2022-44621 Apache Kylin: Command injection by Diagnosis Controller
- CVE-2022-24697 Apache Kylin vulnerable to remote code execution
- CVE-2021-31522 Apache Kylin unsafe class loading
Sources
Also known as GHSA-f6m8-qm7j-fh65.