# CVE-2025-61765: python-socketio vulnerable to arbitrary Python code execution (RCE) through malicious pickle deserialization in certain multi-server deployments

> Attackers with message queue access can execute arbitrary code via unsafe pickle deserialization in multi-server python-socketio deployments.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:A/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2025
- **Updated:** 22 Oct 2025
- **Also known as:** DEBIAN-CVE-2025-61765, GHSA-g8c6-8fjj-2r4m, PYSEC-2026-1854, SUSE-SU-2025:3780-1, UBUNTU-CVE-2025-61765, openSUSE-SU-2025:15613-1

## What is CVE-2025-61765?

CVE-2025-61765 is a medium-severity unsafe deserialization vulnerability in miguelgrinberg python-socketio, published on 6 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

python-socketio is a Python implementation of the Socket.IO realtime client and server. A remote code execution vulnerability in python-socketio versions prior to 5.14.0 allows attackers to execute arbitrary Python code through malicious pickle deserialization in multi-server deployments on which the attacker previously gained access to the message queue that the servers use for internal communications. When Socket.IO servers are configured to use a message queue backend such as Redis for inter-server communication, messages sent between the servers are encoded using the `pickle` Python module. When a server receives one of these messages through the message queue, it assumes it is trusted and immediately deserializes it. The vulnerability stems from deserialization of messages using Python's `pickle.loads()` function. Having previously obtained access to the message queue, the attacker can send a python-socketio server a crafted pickle payload that executes arbitrary code during deserialization via Python's `__reduce__` method. This vulnerability only affects deployments with a compromised message queue. The attack can lead to the attacker executing random code in the context of, and with the privileges of a Socket.IO server process. Single-server systems that do not use a message queue, and multi-server systems with a secure message queue are not vulnerable. In addition to making sure standard security practices are followed in the deployment of the message queue, users of the python-socketio package can upgrade to version 5.14.0 or newer, which remove the `pickle` module and use the much safer JSON encoding for inter-server messaging.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-61765?

3 open source packages ship an affected version, including python-socketio.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `python-socketio` | PyPI | From 0.8.0 | 5.14.0 |
| `python-socketio` | PyPI | From 0.8.0 | 5.14.0 |
| `python-socketio` | PyPI | From 0.8.0 | 5.14.0 |
| `python-python-socketio` | SUSE:Linux Enterprise Module for Python 3 15 SP6 | All versions | 5.7.2-150600.3.3.1 |
| `python-python-socketio` | SUSE:Linux Enterprise Module for Python 3 15 SP7 | All versions | 5.7.2-150600.3.3.1 |
| `python-python-socketio` | openSUSE:Leap 15.6 | All versions | 5.7.2-150600.3.3.1 |
| `python-python-socketio` | openSUSE:Tumbleweed | All versions | 5.14.1-1.1 |

## How do I fix CVE-2025-61765?

Upgrade python-socketio to 5.14.0 or later.

## Is CVE-2025-61765 being exploited?

There is no known exploitation of CVE-2025-61765 in the wild and no public exploit code.

Public exploit code:

- Proof of Concept of an unsafe pickle deserialization vulnerability in Socket.IO (github_poc): https://github.com/locus-x64/CVE-2025-61765_PoC

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-61765 and fix it if it is affected.

What it is: CVE-2025-61765 is a medium-severity unsafe deserialization vulnerability in miguelgrinberg python-socketio, published on 6 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-61765 in the wild and no public exploit code.

Affected packages and fixed versions:
- python-socketio (PyPI): affected from 0.8.0; fixed in 5.14.0
- python-socketio (PyPI): affected from 0.8.0; fixed in 5.14.0
- python-socketio (PyPI): affected from 0.8.0; fixed in 5.14.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-61765/ (Markdown: https://insights.sbomify.com/CVE-2025-61765/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-61765
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-61765
- OSV: https://osv.dev/vulnerability/CVE-2025-61765

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-61765/
Summaries are generated and may contain mistakes; the official description above is the record.
