CVE-2025-61770 Rack's unbounded multipart preamble buffering enables DoS (memory exhaustion)

High 7.5 Published Updated

Remote attackers can cause memory exhaustion and service crashes by sending large multipart preamble data to Rack applications.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-61770?

CVE-2025-61770 is a high-severity denial of service vulnerability in rack, published on 7 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Rack is a modular Ruby web server interface. In versions prior to 2.2.19, 3.1.17, and 3.2.2, `Rack::Multipart::Parser` buffers the entire multipart preamble (bytes before the first boundary) in memory without any size limit. A client can send a large preamble followed by a valid boundary, causing significant memory use and potential process termination due to out-of-memory (OOM) conditions. Remote attackers can trigger large transient memory spikes by including a long preamble in multipart/form-data requests. The impact scales with allowed request sizes and concurrency, potentially causing worker crashes or severe slowdown due to garbage collection. Versions 2.2.19, 3.1.17, and 3.2.2 enforce a preamble size limit (e.g., 16 KiB) or discard preamble data entirely. Workarounds include limiting total request body size at the proxy or web server level and monitoring memory and set per-process limits to prevent OOM conditions.

Weakness: CWE-400

Which versions are affected by CVE-2025-61770?

6 open source packages ship an affected version, including rack. It affects 1 product.

PackageAffectedFixed in
rack RubyGemsAll versions2.2.19
rack RubyGemsAll versions2.2.19
rack RubyGemsFrom 3.13.1.17
rack RubyGemsFrom 3.13.1.17
rack RubyGemsFrom 3.23.2.2
rack RubyGemsFrom 3.23.2.2

Products include Rack Rack.

How do I fix CVE-2025-61770?

Upgrade rack to a fixed version for your release line: 2.2.19, 3.1.17 or 3.2.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-61770 being exploited?

There is no known exploitation of CVE-2025-61770 in the wild and no public exploit code.

Sources

Also known as CLEANSTART-2026-NL32966, CLEANSTART-2026-SK17501, DEBIAN-CVE-2025-61770, GHSA-p543-xpfm-54cp, MINI-3jpg-53cm-3hrg, MINI-4r99-jpr7-vfxr and 13 more.

Is CVE-2025-61770 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free