# CVE-2025-61770: Rack's unbounded multipart preamble buffering enables DoS (memory exhaustion)

> Remote attackers can cause memory exhaustion and service crashes by sending large multipart preamble data to Rack applications.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Oct 2025
- **Updated:** 7 Oct 2025
- **Also known as:** CLEANSTART-2026-NL32966, CLEANSTART-2026-SK17501, DEBIAN-CVE-2025-61770, GHSA-p543-xpfm-54cp, MINI-3jpg-53cm-3hrg, MINI-4r99-jpr7-vfxr, MINI-88g7-hf4c-3q26, MINI-8pv9-cgv5-r88f, MINI-8qfr-7fmg-9jj9, MINI-gpqq-59g2-hc6g, MINI-hrqw-pv74-mfpg, MINI-m6r6-64x3-2gj3, MINI-p3w8-8rhm-9wr5, MINI-p53f-223c-2ppr, MINI-qfg9-rf93-8qhx, MINI-qrc8-v6fh-29q6, MINI-w3p4-8q7x-5m3g, MINI-wgww-p3xf-77wc, UBUNTU-CVE-2025-61770

## What is CVE-2025-61770?

CVE-2025-61770 is a high-severity denial of service vulnerability in rack, published on 7 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Rack is a modular Ruby web server interface. In versions prior to 2.2.19, 3.1.17, and 3.2.2, `Rack::Multipart::Parser` buffers the entire multipart preamble (bytes before the first boundary) in memory without any size limit. A client can send a large preamble followed by a valid boundary, causing significant memory use and potential process termination due to out-of-memory (OOM) conditions. Remote attackers can trigger large transient memory spikes by including a long preamble in multipart/form-data requests. The impact scales with allowed request sizes and concurrency, potentially causing worker crashes or severe slowdown due to garbage collection. Versions 2.2.19, 3.1.17, and 3.2.2 enforce a preamble size limit (e.g., 16 KiB) or discard preamble data entirely. Workarounds include limiting total request body size at the proxy or web server level and monitoring memory and set per-process limits to prevent OOM conditions.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2025-61770?

6 open source packages ship an affected version, including rack. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rack` | RubyGems | All versions | 2.2.19 |
| `rack` | RubyGems | All versions | 2.2.19 |
| `rack` | RubyGems | From 3.1 | 3.1.17 |
| `rack` | RubyGems | From 3.1 | 3.1.17 |
| `rack` | RubyGems | From 3.2 | 3.2.2 |
| `rack` | RubyGems | From 3.2 | 3.2.2 |

Products: Rack Rack.

## How do I fix CVE-2025-61770?

Upgrade rack to a fixed version for your release line: 2.2.19, 3.1.17 or 3.2.2.

## Is CVE-2025-61770 being exploited?

There is no known exploitation of CVE-2025-61770 in the wild and no public exploit code.

## Other vulnerabilities in rack

- [CVE-2026-34785](https://insights.sbomify.com/CVE-2026-34785/): Rack: Local file inclusion in `Rack::Static` via URL Prefix Matching (high 7.5)
- [CVE-2026-34827](https://insights.sbomify.com/CVE-2026-34827/): Rack: Algorithmic-Complexity DoS in Rack::Multipart::Parser (high 7.5)
- [CVE-2026-34829](https://insights.sbomify.com/CVE-2026-34829/): Rack: Denial of Service via Unbounded Multipart File Upload Without Content-Length (high 7.5)
- [CVE-2026-22860](https://insights.sbomify.com/CVE-2026-22860/): Rack has a Directory Traversal via Rack:Directory (high 7.5)
- [CVE-2025-61919](https://insights.sbomify.com/CVE-2025-61919/): Rack is vulnerable to a memory-exhaustion DoS through unbounded URL-encoded body parsing (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-61770 and fix it if it is affected.

What it is: CVE-2025-61770 is a high-severity denial of service vulnerability in rack, published on 7 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-61770 in the wild and no public exploit code.

Affected packages and fixed versions:
- rack (RubyGems): affected all versions; fixed in 2.2.19
- rack (RubyGems): affected all versions; fixed in 2.2.19
- rack (RubyGems): affected from 3.1; fixed in 3.1.17
- rack (RubyGems): affected from 3.1; fixed in 3.1.17
- rack (RubyGems): affected from 3.2; fixed in 3.2.2
- rack (RubyGems): affected from 3.2; fixed in 3.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-61770/ (Markdown: https://insights.sbomify.com/CVE-2025-61770/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-61770
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-61770
- OSV: https://osv.dev/vulnerability/CVE-2025-61770

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-61770/
Summaries are generated and may contain mistakes; the official description above is the record.
