CVE-2025-61771 Rack's multipart parser buffers large non‑file fields entirely in memory, enabling DoS (memory exhaustion)

High 7.5 Published Updated

Attackers can cause denial of service by sending large non-file fields in multipart requests, exhausting memory in Rack applications.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-61771?

CVE-2025-61771 is a high-severity denial of service vulnerability in rack, published on 7 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Rack is a modular Ruby web server interface. In versions prior to 2.2.19, 3.1.17, and 3.2.2, ``Rack::Multipart::Parser` stores non-file form fields (parts without a `filename`) entirely in memory as Ruby `String` objects. A single large text field in a multipart/form-data request (hundreds of megabytes or more) can consume equivalent process memory, potentially leading to out-of-memory (OOM) conditions and denial of service (DoS). Attackers can send large non-file fields to trigger excessive memory usage. Impact scales with request size and concurrency, potentially leading to worker crashes or severe garbage-collection overhead. All Rack applications processing multipart form submissions are affected. Versions 2.2.19, 3.1.17, and 3.2.2 enforce a reasonable size cap for non-file fields (e.g., 2 MiB). Workarounds include restricting maximum request body size at the web-server or proxy layer (e.g., Nginx `client_max_body_size`) and validating and rejecting unusually large form fields at the application level.

Weakness: CWE-400

Which versions are affected by CVE-2025-61771?

6 open source packages ship an affected version, including rack. It affects 1 product.

PackageAffectedFixed in
rack RubyGemsAll versions2.2.19
rack RubyGemsAll versions2.2.19
rack RubyGemsFrom 3.13.1.17
rack RubyGemsFrom 3.13.1.17
rack RubyGemsFrom 3.23.2.2
rack RubyGemsFrom 3.23.2.2

Products include Rack Rack.

How do I fix CVE-2025-61771?

Upgrade rack to a fixed version for your release line: 2.2.19, 3.1.17 or 3.2.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-61771 being exploited?

There is no known exploitation of CVE-2025-61771 in the wild and no public exploit code.

Sources

Also known as CLEANSTART-2026-HZ91324, CLEANSTART-2026-VI91152, DEBIAN-CVE-2025-61771, GHSA-w9pc-fmgc-vxvw, MINI-382j-c87r-7rvc, MINI-592p-9jxp-2p74 and 13 more.

Is CVE-2025-61771 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free