# CVE-2025-61771: Rack's multipart parser buffers large non‑file fields entirely in memory, enabling DoS (memory exhaustion)

> Attackers can cause denial of service by sending large non-file fields in multipart requests, exhausting memory in Rack applications.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Oct 2025
- **Updated:** 7 Oct 2025
- **Also known as:** CLEANSTART-2026-HZ91324, CLEANSTART-2026-VI91152, DEBIAN-CVE-2025-61771, GHSA-w9pc-fmgc-vxvw, MINI-382j-c87r-7rvc, MINI-592p-9jxp-2p74, MINI-h38j-3m72-87f3, MINI-h62q-5xqq-x5h7, MINI-hgrr-vhrm-cphg, MINI-jj87-wjj4-h394, MINI-jjgh-9h82-h979, MINI-mwmc-5f5j-643v, MINI-p446-j28m-6qp3, MINI-qrrp-37r3-hxp5, MINI-vcqq-8mjq-jphf, MINI-vwhg-84x7-m786, MINI-vx4j-q9f6-hcrj, MINI-wrrh-w4mw-qmhp, UBUNTU-CVE-2025-61771

## What is CVE-2025-61771?

CVE-2025-61771 is a high-severity denial of service vulnerability in rack, published on 7 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Rack is a modular Ruby web server interface. In versions prior to 2.2.19, 3.1.17, and 3.2.2, ``Rack::Multipart::Parser` stores non-file form fields (parts without a `filename`) entirely in memory as Ruby `String` objects. A single large text field in a multipart/form-data request (hundreds of megabytes or more) can consume equivalent process memory, potentially leading to out-of-memory (OOM) conditions and denial of service (DoS). Attackers can send large non-file fields to trigger excessive memory usage. Impact scales with request size and concurrency, potentially leading to worker crashes or severe garbage-collection overhead. All Rack applications processing multipart form submissions are affected. Versions 2.2.19, 3.1.17, and 3.2.2 enforce a reasonable size cap for non-file fields (e.g., 2 MiB). Workarounds include restricting maximum request body size at the web-server or proxy layer (e.g., Nginx `client_max_body_size`) and validating and rejecting unusually large form fields at the application level.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2025-61771?

6 open source packages ship an affected version, including rack. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rack` | RubyGems | All versions | 2.2.19 |
| `rack` | RubyGems | All versions | 2.2.19 |
| `rack` | RubyGems | From 3.1 | 3.1.17 |
| `rack` | RubyGems | From 3.1 | 3.1.17 |
| `rack` | RubyGems | From 3.2 | 3.2.2 |
| `rack` | RubyGems | From 3.2 | 3.2.2 |

Products: Rack Rack.

## How do I fix CVE-2025-61771?

Upgrade rack to a fixed version for your release line: 2.2.19, 3.1.17 or 3.2.2.

## Is CVE-2025-61771 being exploited?

There is no known exploitation of CVE-2025-61771 in the wild and no public exploit code.

## Other vulnerabilities in rack

- [CVE-2026-34785](https://insights.sbomify.com/CVE-2026-34785/): Rack: Local file inclusion in `Rack::Static` via URL Prefix Matching (high 7.5)
- [CVE-2026-34827](https://insights.sbomify.com/CVE-2026-34827/): Rack: Algorithmic-Complexity DoS in Rack::Multipart::Parser (high 7.5)
- [CVE-2026-34829](https://insights.sbomify.com/CVE-2026-34829/): Rack: Denial of Service via Unbounded Multipart File Upload Without Content-Length (high 7.5)
- [CVE-2026-22860](https://insights.sbomify.com/CVE-2026-22860/): Rack has a Directory Traversal via Rack:Directory (high 7.5)
- [CVE-2025-61919](https://insights.sbomify.com/CVE-2025-61919/): Rack is vulnerable to a memory-exhaustion DoS through unbounded URL-encoded body parsing (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-61771 and fix it if it is affected.

What it is: CVE-2025-61771 is a high-severity denial of service vulnerability in rack, published on 7 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-61771 in the wild and no public exploit code.

Affected packages and fixed versions:
- rack (RubyGems): affected all versions; fixed in 2.2.19
- rack (RubyGems): affected all versions; fixed in 2.2.19
- rack (RubyGems): affected from 3.1; fixed in 3.1.17
- rack (RubyGems): affected from 3.1; fixed in 3.1.17
- rack (RubyGems): affected from 3.2; fixed in 3.2.2
- rack (RubyGems): affected from 3.2; fixed in 3.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-61771/ (Markdown: https://insights.sbomify.com/CVE-2025-61771/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-61771
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-61771
- OSV: https://osv.dev/vulnerability/CVE-2025-61771

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-61771/
Summaries are generated and may contain mistakes; the official description above is the record.
