CVE-2025-61772 Rack's multipart parser buffers unbounded per-part headers, enabling DoS (memory exhaustion)

High 7.5 Published Updated

Remote attackers can exhaust memory and cause denial of service by sending incomplete multipart headers to Rack's parser.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-61772?

CVE-2025-61772 is a high-severity denial of service vulnerability in rack, published on 7 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Rack is a modular Ruby web server interface. In versions prior to 2.2.19, 3.1.17, and 3.2.2, `Rack::Multipart::Parser` can accumulate unbounded data when a multipart part’s header block never terminates with the required blank line (`CRLFCRLF`). The parser keeps appending incoming bytes to memory without a size cap, allowing a remote attacker to exhaust memory and cause a denial of service (DoS). Attackers can send incomplete multipart headers to trigger high memory use, leading to process termination (OOM) or severe slowdown. The effect scales with request size limits and concurrency. All applications handling multipart uploads may be affected. Versions 2.2.19, 3.1.17, and 3.2.2 cap per-part header size (e.g., 64 KiB). As a workaround, restrict maximum request sizes at the proxy or web server layer (e.g., Nginx `client_max_body_size`).

Weakness: CWE-400

Which versions are affected by CVE-2025-61772?

6 open source packages ship an affected version, including rack. It affects 1 product.

PackageAffectedFixed in
rack RubyGemsAll versions2.2.19
rack RubyGemsAll versions2.2.19
rack RubyGemsFrom 3.13.1.17
rack RubyGemsFrom 3.13.1.17
rack RubyGemsFrom 3.23.2.2
rack RubyGemsFrom 3.23.2.2

Products include Rack Rack.

How do I fix CVE-2025-61772?

Upgrade rack to a fixed version for your release line: 2.2.19, 3.1.17 or 3.2.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-61772 being exploited?

There is no known exploitation of CVE-2025-61772 in the wild and no public exploit code.

Sources

Also known as CLEANSTART-2026-UQ78689, CLEANSTART-2026-UU22048, DEBIAN-CVE-2025-61772, GHSA-wpv5-97wm-hp9c, MINI-3hrm-fcg3-jx3v, MINI-5qr9-4ff7-3787 and 13 more.

Is CVE-2025-61772 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free