# CVE-2025-61772: Rack's multipart parser buffers unbounded per-part headers, enabling DoS (memory exhaustion)

> Remote attackers can exhaust memory and cause denial of service by sending incomplete multipart headers to Rack's parser.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Oct 2025
- **Updated:** 7 Oct 2025
- **Also known as:** CLEANSTART-2026-UQ78689, CLEANSTART-2026-UU22048, DEBIAN-CVE-2025-61772, GHSA-wpv5-97wm-hp9c, MINI-3hrm-fcg3-jx3v, MINI-5qr9-4ff7-3787, MINI-5xj2-358x-3836, MINI-6v9f-8fh3-3hcf, MINI-8cg2-6353-66cf, MINI-cvf2-q92c-j92j, MINI-hjm9-5qqx-q2gq, MINI-j5rm-3773-g782, MINI-jfwc-87mf-hfw6, MINI-jgff-8fr4-99mq, MINI-phfj-h9v6-wf6v, MINI-pr22-vvp2-66pr, MINI-wgfg-vjvc-qvjv, MINI-whj8-f69f-wqjm, UBUNTU-CVE-2025-61772

## What is CVE-2025-61772?

CVE-2025-61772 is a high-severity denial of service vulnerability in rack, published on 7 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Rack is a modular Ruby web server interface. In versions prior to 2.2.19, 3.1.17, and 3.2.2, `Rack::Multipart::Parser` can accumulate unbounded data when a multipart part’s header block never terminates with the required blank line (`CRLFCRLF`). The parser keeps appending incoming bytes to memory without a size cap, allowing a remote attacker to exhaust memory and cause a denial of service (DoS). Attackers can send incomplete multipart headers to trigger high memory use, leading to process termination (OOM) or severe slowdown. The effect scales with request size limits and concurrency. All applications handling multipart uploads may be affected. Versions 2.2.19, 3.1.17, and 3.2.2 cap per-part header size (e.g., 64 KiB). As a workaround, restrict maximum request sizes at the proxy or web server layer (e.g., Nginx `client_max_body_size`).

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2025-61772?

6 open source packages ship an affected version, including rack. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rack` | RubyGems | All versions | 2.2.19 |
| `rack` | RubyGems | All versions | 2.2.19 |
| `rack` | RubyGems | From 3.1 | 3.1.17 |
| `rack` | RubyGems | From 3.1 | 3.1.17 |
| `rack` | RubyGems | From 3.2 | 3.2.2 |
| `rack` | RubyGems | From 3.2 | 3.2.2 |

Products: Rack Rack.

## How do I fix CVE-2025-61772?

Upgrade rack to a fixed version for your release line: 2.2.19, 3.1.17 or 3.2.2.

## Is CVE-2025-61772 being exploited?

There is no known exploitation of CVE-2025-61772 in the wild and no public exploit code.

## Other vulnerabilities in rack

- [CVE-2026-34785](https://insights.sbomify.com/CVE-2026-34785/): Rack: Local file inclusion in `Rack::Static` via URL Prefix Matching (high 7.5)
- [CVE-2026-34827](https://insights.sbomify.com/CVE-2026-34827/): Rack: Algorithmic-Complexity DoS in Rack::Multipart::Parser (high 7.5)
- [CVE-2026-34829](https://insights.sbomify.com/CVE-2026-34829/): Rack: Denial of Service via Unbounded Multipart File Upload Without Content-Length (high 7.5)
- [CVE-2026-22860](https://insights.sbomify.com/CVE-2026-22860/): Rack has a Directory Traversal via Rack:Directory (high 7.5)
- [CVE-2025-61919](https://insights.sbomify.com/CVE-2025-61919/): Rack is vulnerable to a memory-exhaustion DoS through unbounded URL-encoded body parsing (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-61772 and fix it if it is affected.

What it is: CVE-2025-61772 is a high-severity denial of service vulnerability in rack, published on 7 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-61772 in the wild and no public exploit code.

Affected packages and fixed versions:
- rack (RubyGems): affected all versions; fixed in 2.2.19
- rack (RubyGems): affected all versions; fixed in 2.2.19
- rack (RubyGems): affected from 3.1; fixed in 3.1.17
- rack (RubyGems): affected from 3.1; fixed in 3.1.17
- rack (RubyGems): affected from 3.2; fixed in 3.2.2
- rack (RubyGems): affected from 3.2; fixed in 3.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-61772/ (Markdown: https://insights.sbomify.com/CVE-2025-61772/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-61772
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-61772
- OSV: https://osv.dev/vulnerability/CVE-2025-61772

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-61772/
Summaries are generated and may contain mistakes; the official description above is the record.
