# CVE-2025-61776: Dependency-Track possibly discloses private NuGet repository credentials to api.nuget.org

> Dependency-Track may leak private NuGet repository credentials and internal component details to api.nuget.org under specific configuration conditions.

- **Severity:** Medium 4.7 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 7 Oct 2025
- **Updated:** 7 Oct 2025
- **Also known as:** GHSA-83g2-vgqh-mgxc

## What is CVE-2025-61776?

CVE-2025-61776 is a medium-severity vulnerability in DependencyTrack dependency-track, published on 7 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Dependency-Track is a component analysis platform that allows organizations to identify and reduce risk in the software supply chain. Prior to version 4.13.5, Dependency-Track may send credentials meant for a private NuGet repository to `api.nuget.org` via the HTTP `Authorization` header, and may disclose names and versions of components marked as internal to `api.nuget.org`. This can happen if the Dependency-Track instance contains .NET components, a custom NuGet repository has been configured, the custom repository has been configured with authentication credentials, and the repository server does not provide `PackageBaseAddress` resource in its service index. The issue has been fixed in Dependency-Track 4.13.5. Some workarounds are avaialble. Disable custom NuGet repositories until the patch has been applied, invalidate the previously used credentials, and generate new credentials for usage after the patch has been applied.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2025-61776?


## How do I fix CVE-2025-61776?

No fix has been published for CVE-2025-61776 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-61776 being exploited?

There is no known exploitation of CVE-2025-61776 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-61776 and fix it if it is affected.

What it is: CVE-2025-61776 is a medium-severity vulnerability in DependencyTrack dependency-track, published on 7 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-61776 in the wild and no public exploit code.

Affected product: DependencyTrack dependency-track. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-61776/ (Markdown: https://insights.sbomify.com/CVE-2025-61776/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-61776
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-61776
- OSV: https://osv.dev/vulnerability/CVE-2025-61776

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-61776/
Summaries are generated and may contain mistakes; the official description above is the record.
