CVE-2025-61778 Akka.Remote TLS did not properly implement certificate-based authentication
Untrusted parties can connect to Akka.NET clusters using TLS because mutual authentication was not enforced, allowing unauthorized communication.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-61778?
CVE-2025-61778 is a critical authentication bypass vulnerability in akkadotnet akka.net, published on 6 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Akka.NET is a .NET port of the Akka project from the Scala / Java community. In all versions of Akka.Remote from v1.2.0 to v1.5.51, TLS could be enabled via our `akka.remote.dot-netty.tcp` transport and this would correctly enforce private key validation on the server-side of inbound connections. Akka.Remote, however, never asked the outbound-connecting client to present ITS certificate - therefore it's possible for untrusted parties to connect to a private key'd Akka.NET cluster and begin communicating with it without any certificate. The issue here is that for certificate-based authentication to work properly, ensuring that all members of the Akka.Remote network are secured with the same private key, Akka.Remote needed to implement mutual TLS. This was not the case before Akka.NET v1.5.52. Those who run Akka.NET inside a private network that they fully control or who were never using TLS in the first place are now affected by the bug. However, those who use TLS to secure their networks must upgrade to Akka.NET V1.5.52 or later. One patch forces "fail fast" semantics if TLS is enabled but the private key is missing or invalid. Previous versions would only check that once connection attempts occurred. The second patch, a critical fix, enforces mutual TLS (mTLS) by default, so both parties must be keyed using the same certificate. As a workaround, avoid exposing the application publicly to avoid the vulnerability having a practical impact on one's application. However, upgrading to version 1.5.52 is still recommended by the maintainers.
Which versions are affected by CVE-2025-61778?
4 open source packages ship an affected version, including Akka.Cluster and Akka.Remote.
| Package | Affected | Fixed in |
|---|---|---|
Akka.Cluster NuGet | From 1.2.0 | 1.5.52 |
Akka.Cluster NuGet | From 1.2.0 | 1.5.52 |
Akka.Remote NuGet | From 1.2.0 | 1.5.52 |
Akka.Remote NuGet | From 1.2.0 | 1.5.52 |
How do I fix CVE-2025-61778?
Upgrade Akka.Cluster to 1.5.52 or later.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2025-61778 being exploited?
There is no known exploitation of CVE-2025-61778 in the wild and no public exploit code.
Sources
Also known as GHSA-jhpv-4q4f-43g5.