# CVE-2025-61780: Rack has Possible Information Disclosure Vulnerability

> Attackers can bypass proxy access controls to access protected internal endpoints by crafting specific headers in Rack::Sendfile.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Oct 2025
- **Updated:** 10 Oct 2025
- **Also known as:** CLEANSTART-2026-HO19975, DEBIAN-CVE-2025-61780, GHSA-r657-rxjc-j557, MINI-29cw-v24q-q78p, MINI-2qvh-mwcf-7w25, MINI-4fh9-fgp7-9qhq, MINI-62p4-fjg7-cgc8, MINI-7pvr-qvr4-8v87, MINI-8h58-84f5-xp88, MINI-c76c-6vw7-9hr3, MINI-gf53-ch35-f3j5, MINI-mmh5-wr2c-jrff, MINI-qf6f-rq74-mjvw, MINI-qg6c-693g-w8pw, MINI-qj9w-cj9v-cq27, MINI-w2c2-6q82-q536, MINI-xjj4-mwpr-h2m3, UBUNTU-CVE-2025-61780

## What is CVE-2025-61780?

CVE-2025-61780 is a medium-severity vulnerability in rack, published on 10 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Rack is a modular Ruby web server interface. Prior to versions 2.2.20, 3.1.18, and 3.2.3, a possible information disclosure vulnerability existed in `Rack::Sendfile` when running behind a proxy that supports `x-sendfile` headers (such as Nginx). Specially crafted headers could cause `Rack::Sendfile` to miscommunicate with the proxy and trigger unintended internal requests, potentially bypassing proxy-level access restrictions. When `Rack::Sendfile` received untrusted `x-sendfile-type` or `x-accel-mapping` headers from a client, it would interpret them as proxy configuration directives. This could cause the middleware to send a "redirect" response to the proxy, prompting it to reissue a new internal request that was not subject to the proxy's access controls. An attacker could exploit this by setting a crafted `x-sendfile-type: x-accel-redirect` header, setting a crafted `x-accel-mapping` header, and requesting a path that qualifies for proxy-based acceleration. Attackers could bypass proxy-enforced restrictions and access internal endpoints intended to be protected (such as administrative pages). The vulnerability did not allow arbitrary file reads but could expose sensitive application routes. This issue only affected systems meeting all of the following conditions: The application used `Rack::Sendfile` with a proxy that supports `x-accel-redirect` (e.g., Nginx); the proxy did **not** always set or remove the `x-sendfile-type` and `x-accel-mapping` headers; and the application exposed an endpoint that returned a body responding to `.to_path`. Users should upgrade to Rack versions 2.2.20, 3.1.18, or 3.2.3, which require explicit configuration to enable `x-accel-redirect`. Alternatively, configure the proxy to always set or strip the header, or in Rails applications, disable sendfile completely.

Weakness: CWE-913 (Improper Control of Dynamically-Managed Code Resources), CWE-441 (Unintended Proxy or Intermediary), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-61780?

6 open source packages ship an affected version, including rack. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rack` | RubyGems | All versions | 2.2.20 |
| `rack` | RubyGems | All versions | 2.2.20 |
| `rack` | RubyGems | From 3.0 | 3.1.18 |
| `rack` | RubyGems | From 3.0 | 3.1.18 |
| `rack` | RubyGems | From 3.2 | 3.2.3 |
| `rack` | RubyGems | From 3.2 | 3.2.3 |

Products: Rack Rack.

## How do I fix CVE-2025-61780?

Upgrade rack to a fixed version for your release line: 2.2.20, 3.1.18 or 3.2.3.

## Is CVE-2025-61780 being exploited?

There is no known exploitation of CVE-2025-61780 in the wild and no public exploit code.

## Other vulnerabilities in rack

- [CVE-2026-34785](https://insights.sbomify.com/CVE-2026-34785/): Rack: Local file inclusion in `Rack::Static` via URL Prefix Matching (high 7.5)
- [CVE-2026-34827](https://insights.sbomify.com/CVE-2026-34827/): Rack: Algorithmic-Complexity DoS in Rack::Multipart::Parser (high 7.5)
- [CVE-2026-34829](https://insights.sbomify.com/CVE-2026-34829/): Rack: Denial of Service via Unbounded Multipart File Upload Without Content-Length (high 7.5)
- [CVE-2026-22860](https://insights.sbomify.com/CVE-2026-22860/): Rack has a Directory Traversal via Rack:Directory (high 7.5)
- [CVE-2025-61919](https://insights.sbomify.com/CVE-2025-61919/): Rack is vulnerable to a memory-exhaustion DoS through unbounded URL-encoded body parsing (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-61780 and fix it if it is affected.

What it is: CVE-2025-61780 is a medium-severity vulnerability in rack, published on 10 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-61780 in the wild and no public exploit code.

Affected packages and fixed versions:
- rack (RubyGems): affected all versions; fixed in 2.2.20
- rack (RubyGems): affected all versions; fixed in 2.2.20
- rack (RubyGems): affected from 3.0; fixed in 3.1.18
- rack (RubyGems): affected from 3.0; fixed in 3.1.18
- rack (RubyGems): affected from 3.2; fixed in 3.2.3
- rack (RubyGems): affected from 3.2; fixed in 3.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-61780/ (Markdown: https://insights.sbomify.com/CVE-2025-61780/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-61780
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-61780
- OSV: https://osv.dev/vulnerability/CVE-2025-61780

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-61780/
Summaries are generated and may contain mistakes; the official description above is the record.
