# CVE-2025-61781: GraphQL IDOR allows authenticated user to delete workspace content of other users

> Authenticated users can delete other users' workspaces due to missing ownership checks in GraphQL mutations.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jan 2026
- **Updated:** 5 Jan 2026
- **Also known as:** GHSA-pr6m-q4g7-342c, PYSEC-2026-116

## What is CVE-2025-61781?

CVE-2025-61781 is a high-severity missing authorization vulnerability in OpenCTI-Platform opencti, published on 5 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenCTI is an open source platform for managing cyber threat intelligence knowledge and observables. Prior to version 6.8.1, the GraphQL mutation "WorkspacePopoverDeletionMutation" allows users to delete workspace-related objects such as dashboards and investigation cases. However, the mutation lacks proper authorization checks to verify ownership of the targeted resources.
An attacker can exploit this by supplying an active UUID of another user. Since the API does not validate whether the requester owns the resource, the mutation executes successfully, resulting in unauthorized deletion of the entire workspace. Version 6.8.1 fixes the issue.

Weakness: CWE-915 (Improperly Controlled Modification of Dynamically-Determined Object Attributes), CWE-566 (Authorization Bypass Through User-Controlled SQL Primary Key), CWE-863 (Incorrect Authorization), CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2025-61781?

1 open source package ship an affected version, including pycti. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pycti` | PyPI | All versions | 6.8.1 |

Products: Citeum Opencti.

## How do I fix CVE-2025-61781?

Upgrade pycti to 6.8.1 or later.

## Is CVE-2025-61781 being exploited?

There is no known exploitation of CVE-2025-61781 in the wild and no public exploit code.

## Other vulnerabilities in OpenCTI-Platform opencti

- [CVE-2026-27960](https://insights.sbomify.com/CVE-2026-27960/): OpenCTI privilege escalation and unauthenticated access via default admin account (critical 9.8)
- [CVE-2026-39980](https://insights.sbomify.com/CVE-2026-39980/): OpenCTI affected by RCE via notifier template (critical 9.1)
- [CVE-2025-24977](https://insights.sbomify.com/CVE-2025-24977/): OpenCTI has remote code execution and sensitive secrets exposed through web hook (critical 9.1)
- [CVE-2024-26139](https://insights.sbomify.com/CVE-2024-26139/): OpenCTI Authenticated Privilege Escalation (high 8.3)
- [CVE-2024-45404](https://insights.sbomify.com/CVE-2024-45404/): OpenCTI's lack of Rate Limit lead to OTP brute forcing (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-61781 and fix it if it is affected.

What it is: CVE-2025-61781 is a high-severity missing authorization vulnerability in OpenCTI-Platform opencti, published on 5 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-61781 in the wild and no public exploit code.

Affected packages and fixed versions:
- pycti (PyPI): affected all versions; fixed in 6.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-61781/ (Markdown: https://insights.sbomify.com/CVE-2025-61781/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-61781
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-61781
- OSV: https://osv.dev/vulnerability/CVE-2025-61781

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-61781/
Summaries are generated and may contain mistakes; the official description above is the record.
