# CVE-2025-61782: Open Redirect in OpenCTI's SAML Authentication Flow

> Attackers can redirect users to malicious sites via the SAML callback, enabling phishing and credential theft in OpenCTI.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Jan 2026
- **Updated:** 7 Jan 2026
- **Also known as:** GHSA-jc3f-c62g-v7qw, PYSEC-2026-2264

## What is CVE-2025-61782?

CVE-2025-61782 is a medium-severity vulnerability in OpenCTI-Platform opencti, published on 7 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

OpenCTI is an open source platform for managing cyber threat intelligence knowledge and observables. Prior to version 6.8.3, an open redirect vulnerability exists in the OpenCTI platform's SAML authentication endpoint (/auth/saml/callback). By manipulating the RelayState parameter, an attacker can force the server to issue a 302 redirect to any external URL, enabling phishing, credential theft, and arbitrary site redirection. This issue has been patched in version 6.8.3.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2025-61782?

1 open source package ship an affected version, including pycti. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pycti` | PyPI | All versions | 6.8.3 |

Products: Citeum Opencti.

## How do I fix CVE-2025-61782?

Upgrade pycti to 6.8.3 or later.

## Is CVE-2025-61782 being exploited?

There is no known exploitation of CVE-2025-61782 in the wild and no public exploit code.

## Other vulnerabilities in OpenCTI-Platform opencti

- [CVE-2026-27960](https://insights.sbomify.com/CVE-2026-27960/): OpenCTI privilege escalation and unauthenticated access via default admin account (critical 9.8)
- [CVE-2026-39980](https://insights.sbomify.com/CVE-2026-39980/): OpenCTI affected by RCE via notifier template (critical 9.1)
- [CVE-2025-24977](https://insights.sbomify.com/CVE-2025-24977/): OpenCTI has remote code execution and sensitive secrets exposed through web hook (critical 9.1)
- [CVE-2024-26139](https://insights.sbomify.com/CVE-2024-26139/): OpenCTI Authenticated Privilege Escalation (high 8.3)
- [CVE-2024-45404](https://insights.sbomify.com/CVE-2024-45404/): OpenCTI's lack of Rate Limit lead to OTP brute forcing (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-61782 and fix it if it is affected.

What it is: CVE-2025-61782 is a medium-severity vulnerability in OpenCTI-Platform opencti, published on 7 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-61782 in the wild and no public exploit code.

Affected packages and fixed versions:
- pycti (PyPI): affected all versions; fixed in 6.8.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-61782/ (Markdown: https://insights.sbomify.com/CVE-2025-61782/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-61782
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-61782
- OSV: https://osv.dev/vulnerability/CVE-2025-61782

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-61782/
Summaries are generated and may contain mistakes; the official description above is the record.
