{"answers":{"affected":"3 open source packages ship an affected version, including social-auth-app-django.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-61783 exists.","fix":"Upgrade social-auth-app-django to 5.6.0 or later.","what":"CVE-2025-61783 is a medium-severity authentication bypass vulnerability in python-social-auth social-app-django, published on 9 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-61783 and fix it if it is affected.\n\nWhat it is: CVE-2025-61783 is a medium-severity authentication bypass vulnerability in python-social-auth social-app-django, published on 9 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-61783 exists.\n\nAffected packages and fixed versions:\n- social-auth-app-django (PyPI): affected all versions; fixed in 5.6.0\n- social-auth-app-django (PyPI): affected all versions; fixed in 5.6.0\n- social-auth-app-django (PyPI): affected all versions; fixed in 5.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-61783/ (Markdown: https://insights.sbomify.com/CVE-2025-61783/index.md)","id":"CVE-2025-61783","markdown":"https://insights.sbomify.com/CVE-2025-61783/index.md","name":"CVE-2025-61783","record":{"aliases":["DEBIAN-CVE-2025-61783","GHSA-wv4w-6qv2-qqfg","PYSEC-2026-1932","UBUNTU-CVE-2025-61783","openSUSE-SU-2026:10499-1"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Python social auth library","requires_auth":"none","summary":"Attackers can take over accounts by exploiting unsafe email association during authentication, even when the feature is disabled.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-303","name":"Incorrect Implementation of Authentication Algorithm"}],"description":"Python Social Auth is a social authentication/registration mechanism. In versions prior to 5.6.0, upon authentication, the user could be associated by e-mail even if the `associate_by_email` pipeline was not included. This could lead to account compromise when a third-party authentication service does not validate provided e-mail addresses or doesn't require unique e-mail addresses. Version 5.6.0 contains a patch. As a workaround, review the authentication service policy on e-mail addresses; many will not allow exploiting this vulnerability.","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Python Social Auth - Django has unsafe account association","id":"CVE-2025-61783","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":4,"n_references":6,"next":{"headline":"LLaMA Factory's Chat API has Critical SSRF and LFI Vulnerabilities","id":"CVE-2025-61784"},"packages":[{"ecosystem":"PyPI","fixed":["5.6.0"],"introduced":["0"],"last_affected":[],"package":"social-auth-app-django","purl":null,"source":"GHSA-wv4w-6qv2-qqfg"},{"ecosystem":"PyPI","fixed":["5.6.0"],"introduced":["0"],"last_affected":[],"package":"social-auth-app-django","purl":"pkg:pypi/social-auth-app-django","source":"GHSA-wv4w-6qv2-qqfg"},{"ecosystem":"PyPI","fixed":["5.6.0"],"introduced":["0"],"last_affected":[],"package":"social-auth-app-django","purl":"pkg:pypi/social-auth-app-django","source":"PYSEC-2026-1932"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["5.7.0-1.1"],"introduced":["0"],"last_affected":[],"package":"python-social-auth-app-django","purl":"pkg:rpm/opensuse/python-social-auth-app-django\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10499-1"}],"prev":{"headline":"Open Redirect in OpenCTI's SAML Authentication Flow","id":"CVE-2025-61782"},"products":["social-app-django"],"published":"2025-10-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-15","vendors":["python-social-auth"]},"summary":"Attackers can take over accounts by exploiting unsafe email association during authentication, even when the feature is disabled.","url":"https://insights.sbomify.com/CVE-2025-61783/"}