# CVE-2025-61785: Deno's --deny-write check does not prevent permission bypass

> Attackers can bypass Deno's write permission restrictions to modify file timestamps using specific file stream APIs.

- **Severity:** Low 3.3 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Oct 2025
- **Updated:** 8 Oct 2025
- **Also known as:** GHSA-vg2r-rmgp-cgqj, JLSEC-2026-111

## What is CVE-2025-61785?

CVE-2025-61785 is a low-severity vulnerability in denoland deno, published on 8 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Deno is a JavaScript, TypeScript, and WebAssembly runtime. In versions prior to 2.5.3 and 2.2.15, `Deno.FsFile.prototype.utime` and `Deno.FsFile.prototype.utimeSync` are not limited by the permission model check `--deny-write=./`. It's possible to change to change the access (`atime`) and modification (`mtime`) times on the file stream resource even when the file is opened with `read` only permission (and `write`: `false`) and file write operations are not allowed (the script is executed with `--deny-write=./`). Similar APIs like `Deno.utime` and `Deno.utimeSync` require `allow-write` permission, however, when a file is opened, even with read only flags and deny-write permission, it's still possible to change the access (`atime`) and modification (`mtime`) times, and thus bypass the permission model. Versions 2.5.3 and 2.2.15 fix the issue.

Weakness: CWE-266 (Incorrect Privilege Assignment)

## Which versions are affected by CVE-2025-61785?

2 open source packages ship an affected version, including deno. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `deno` | crates.io | All versions | 2.5.3 |
| `deno` | crates.io | All versions | 2.5.3 |

Products: Deno Deno.

## How do I fix CVE-2025-61785?

Upgrade deno to 2.5.3 or later.

## Is CVE-2025-61785 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-61785 exists.

## Other vulnerabilities in denoland deno

- [CVE-2023-28445](https://insights.sbomify.com/CVE-2023-28445/): Deno improperly handles resizable ArrayBuffer (critical 10.0)
- [CVE-2022-24783](https://insights.sbomify.com/CVE-2022-24783/): Sandbox bypass leading to arbitrary code execution in Deno (critical 10.0)
- [CVE-2021-32619](https://insights.sbomify.com/CVE-2021-32619/): Static imports inside dynamically imported modules do not adhere to permission checks (critical 9.8)
- [CVE-2026-22863](https://insights.sbomify.com/CVE-2026-22863/): Deno node:crypto doesn't finalize cipher (critical 9.2)
- [CVE-2024-27936](https://insights.sbomify.com/CVE-2024-27936/): Deno interactive permission prompt spoofing via improper ANSI stripping (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-61785 and fix it if it is affected.

What it is: CVE-2025-61785 is a low-severity vulnerability in denoland deno, published on 8 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-61785 exists.

Affected packages and fixed versions:
- deno (crates.io): affected all versions; fixed in 2.5.3
- deno (crates.io): affected all versions; fixed in 2.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-61785/ (Markdown: https://insights.sbomify.com/CVE-2025-61785/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-61785
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-61785
- OSV: https://osv.dev/vulnerability/CVE-2025-61785

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-61785/
Summaries are generated and may contain mistakes; the official description above is the record.
