# CVE-2025-61787: Deno is Vulnerable to Command Injection on Windows During Batch File Execution

> Attackers can execute arbitrary commands on Windows systems by exploiting how Deno handles batch file execution via CreateProcess.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Oct 2025
- **Updated:** 8 Oct 2025
- **Also known as:** GHSA-m2gf-x3f6-8hq3, JLSEC-2026-113

## What is CVE-2025-61787?

CVE-2025-61787 is a high-severity command injection vulnerability in denoland deno, published on 8 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Deno is a JavaScript, TypeScript, and WebAssembly runtime. Versions prior to 2.5.3 and 2.2.15 are vulnerable to Command Line Injection attacks on Windows when batch files are executed. In Windows, ``CreateProcess()`` always implicitly spawns ``cmd.exe`` if a batch file (.bat, .cmd, etc.) is being executed even if the application does not specify it via the command line. This makes Deno vulnerable to a command injection attack on Windows. Versions 2.5.3 and 2.2.15 fix the issue.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2025-61787?

2 open source packages ship an affected version, including deno. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `deno` | crates.io | All versions | 2.5.2 |
| `deno` | crates.io | All versions | 2.5.2 |

Products: Deno Deno.

## How do I fix CVE-2025-61787?

Upgrade deno to 2.5.2 or later.

## Is CVE-2025-61787 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-61787 exists.

## Other vulnerabilities in denoland deno

- [CVE-2023-28445](https://insights.sbomify.com/CVE-2023-28445/): Deno improperly handles resizable ArrayBuffer (critical 10.0)
- [CVE-2022-24783](https://insights.sbomify.com/CVE-2022-24783/): Sandbox bypass leading to arbitrary code execution in Deno (critical 10.0)
- [CVE-2021-32619](https://insights.sbomify.com/CVE-2021-32619/): Static imports inside dynamically imported modules do not adhere to permission checks (critical 9.8)
- [CVE-2026-22863](https://insights.sbomify.com/CVE-2026-22863/): Deno node:crypto doesn't finalize cipher (critical 9.2)
- [CVE-2024-27936](https://insights.sbomify.com/CVE-2024-27936/): Deno interactive permission prompt spoofing via improper ANSI stripping (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-61787 and fix it if it is affected.

What it is: CVE-2025-61787 is a high-severity command injection vulnerability in denoland deno, published on 8 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-61787 exists.

Affected packages and fixed versions:
- deno (crates.io): affected all versions; fixed in 2.5.2
- deno (crates.io): affected all versions; fixed in 2.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-61787/ (Markdown: https://insights.sbomify.com/CVE-2025-61787/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-61787
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-61787
- OSV: https://osv.dev/vulnerability/CVE-2025-61787

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-61787/
Summaries are generated and may contain mistakes; the official description above is the record.
