CVE-2025-61788 Opencast Paella Player 7 vulnerable to Cross-Site-Scripting
Attackers with write access can inject malicious scripts into media metadata, leading to script execution in viewers' browsers.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2025-61788?
CVE-2025-61788 is a medium-severity cross-site scripting vulnerability in opencast, published on 8 Oct 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Opencast is a free, open-source platform to support the management of educational audio and video content. Prior to Opencast 17.8 and 18.2, the paella would include and render some user inputs (metadata like title, description, etc.) unfiltered and unmodified. The vulnerability allows attackers to inject and malicious HTML and JavaScript in the player, which would then be executed in the browsers of users watching the prepared media. This can then be used to modify the site or to execute actions in the name of logged-in users. To inject malicious metadata, an attacker needs write access to the system. For example, the ability to upload media and modify metadata. This cannot be exploited by unauthenticated users. This issue is fixed in Opencast 17.8 and 18.2.
Weakness: CWE-79
Which versions are affected by CVE-2025-61788?
2 open source packages ship an affected version, including org.opencastproject:opencast-common. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.opencastproject:opencast-common Maven | All versions to 16.10 | None |
org.opencastproject:opencast-common Maven | All versions to 16.10 | None |
Products include Apereo Opencast.
How do I fix CVE-2025-61788?
No fix has been published for CVE-2025-61788 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2025-61788 being exploited?
There is no known exploitation of CVE-2025-61788 in the wild and no public exploit code.
Other vulnerabilities in opencast
- CVE-2021-43821 Files Accessible to External Parties in Opencast
- CVE-2020-5206 Authentication Bypass For Endpoints With Anonymous Access in OpenCast
- CVE-2021-32623 Opencast vulnerable to billion laughs attack (XML bomb)
- CVE-2020-5229 Opencast stores passwords using outdated MD5 hash algorithm
- CVE-2020-5230 Opencast uses unsafe identifiers
Sources
Also known as GHSA-m2vg-rmq6-p62r.