# CVE-2025-61788: Opencast Paella Player 7 vulnerable to Cross-Site-Scripting

> Attackers with write access can inject malicious scripts into media metadata, leading to script execution in viewers' browsers.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 8 Oct 2025
- **Updated:** 8 Oct 2025
- **Also known as:** GHSA-m2vg-rmq6-p62r

## What is CVE-2025-61788?

CVE-2025-61788 is a medium-severity cross-site scripting vulnerability in opencast, published on 8 Oct 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Opencast is a free, open-source platform to support the management of educational audio and video content. Prior to Opencast 17.8 and 18.2, the paella would include and render some user inputs (metadata like title, description, etc.) unfiltered and unmodified. The vulnerability allows attackers to inject and malicious HTML and JavaScript in the player, which would then be executed in the browsers of users watching the prepared media. This can then be used to modify the site or to execute actions in the name of logged-in users. To inject malicious metadata, an attacker needs write access to the system. For example, the ability to upload media and modify metadata. This cannot be exploited by unauthenticated users. This issue is fixed in Opencast 17.8 and 18.2.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-61788?

2 open source packages ship an affected version, including org.opencastproject:opencast-common. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.opencastproject:opencast-common` | Maven | All versions to 16.10 | None |
| `org.opencastproject:opencast-common` | Maven | All versions to 16.10 | None |

Products: Apereo Opencast.

## How do I fix CVE-2025-61788?

No fix has been published for CVE-2025-61788 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-61788 being exploited?

There is no known exploitation of CVE-2025-61788 in the wild and no public exploit code.

## Other vulnerabilities in opencast

- [CVE-2021-43821](https://insights.sbomify.com/CVE-2021-43821/): Files Accessible to External Parties in Opencast (critical 9.9)
- [CVE-2020-5206](https://insights.sbomify.com/CVE-2020-5206/): Authentication Bypass For Endpoints With Anonymous Access in OpenCast (high 8.7)
- [CVE-2021-32623](https://insights.sbomify.com/CVE-2021-32623/): Opencast vulnerable to billion laughs attack (XML bomb) (high 8.1)
- [CVE-2020-5229](https://insights.sbomify.com/CVE-2020-5229/): Opencast stores passwords using outdated MD5 hash algorithm (high 7.7)
- [CVE-2020-5230](https://insights.sbomify.com/CVE-2020-5230/): Opencast uses unsafe identifiers (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-61788 and fix it if it is affected.

What it is: CVE-2025-61788 is a medium-severity cross-site scripting vulnerability in opencast, published on 8 Oct 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-61788 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.opencastproject:opencast-common (Maven): affected all versions up to 16.10; no fix listed
- org.opencastproject:opencast-common (Maven): affected all versions up to 16.10; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-61788/ (Markdown: https://insights.sbomify.com/CVE-2025-61788/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-61788
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-61788
- OSV: https://osv.dev/vulnerability/CVE-2025-61788

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-61788/
Summaries are generated and may contain mistakes; the official description above is the record.
