# CVE-2025-61795: Apache Tomcat: Delayed cleaning of multi-part upload temporary files may lead to DoS

> Attackers can cause denial of service by triggering errors during multipart uploads, leaving temporary files that exhaust disk space before garbage collection.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Oct 2025
- **Updated:** 12 May 2026
- **Also known as:** BIT-tomcat-2025-61795, DEBIAN-CVE-2025-61795, GHSA-hgrr-935x-pq79, ROOT-APP-MAVEN-CVE-2025-61795, UBUNTU-CVE-2025-61795

## What is CVE-2025-61795?

CVE-2025-61795 is a medium-severity denial of service vulnerability in Apache Tomcat, published on 27 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper Resource Shutdown or Release vulnerability in Apache Tomcat.

If an error occurred (including exceeding limits) during the processing of a multipart upload, temporary copies of the uploaded parts written to disc were not cleaned up immediately but left for the garbage collection process to delete. Depending on JVM settings, application memory usage and application load, it was possible that space for the temporary copies of uploaded parts would be filled faster than GC cleared it, leading to a DoS.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.11, from 10.1.0-M1 through 10.1.46, from 9.0.0.M1 through 9.0.109.

The following versions were EOL at the time the CVE was created but are 
known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected.
Users are recommended to upgrade to version 11.0.12 or later, 10.1.47 or later or 9.0.110 or later which fixes the issue.

Weakness: CWE-404 (Improper Resource Shutdown or Release)

## Which versions are affected by CVE-2025-61795?

25 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 10.1.0-M1 | 10.1.47 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 10.1.0-M1 | 10.1.47 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 11.0.0-M1 | 11.0.12 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 11.0.0-M1 | 11.0.12 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 8.5.0 to 8.5.100 | None |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 8.5.0 to 8.5.100 | None |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 9.0.0.M1 | 9.0.110 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 9.0.0.M1 | 9.0.110 |
| `tomcat` | Bitnami | All versions | 9.0.110, 10.1.47, 11.0.12 |
| `org.apache.tomcat:tomcat` | Maven | From 10.1.0-M1 | 10.1.47 |
| `org.apache.tomcat:tomcat` | Maven | From 10.1.0-M1 | 10.1.47 |
| `org.apache.tomcat:tomcat` | Maven | From 11.0.0-M1 | 11.0.12 |
| `org.apache.tomcat:tomcat` | Maven | From 11.0.0-M1 | 11.0.12 |
| `org.apache.tomcat:tomcat` | Maven | From 8.5.0 to 8.5.100 | None |
| `org.apache.tomcat:tomcat` | Maven | From 8.5.0 to 8.5.100 | None |
| `org.apache.tomcat:tomcat` | Maven | From 9.0.0.M1 | 9.0.110 |
| `org.apache.tomcat:tomcat` | Maven | From 9.0.0.M1 | 9.0.110 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 10.1.0-M1 | 10.1.47 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 10.1.0-M1 | 10.1.47 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 11.0.0-M1 | 11.0.12 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 11.0.0-M1 | 11.0.12 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 8.5.0 to 8.5.100 | None |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 8.5.0 to 8.5.100 | None |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 9.0.0.M1 | 9.0.110 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 9.0.0.M1 | 9.0.110 |

Products: Apache Tomcat.

## How do I fix CVE-2025-61795?

Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.47, 11.0.12 or 9.0.110.

## Is CVE-2025-61795 being exploited?

There is no known exploitation of CVE-2025-61795 in the wild and no public exploit code.

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-61795 and fix it if it is affected.

What it is: CVE-2025-61795 is a medium-severity denial of service vulnerability in Apache Tomcat, published on 27 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-61795 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 10.1.0-M1; fixed in 10.1.47
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 10.1.0-M1; fixed in 10.1.47
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 11.0.0-M1; fixed in 11.0.12
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 11.0.0-M1; fixed in 11.0.12
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 8.5.0 up to 8.5.100; no fix listed
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 8.5.0 up to 8.5.100; no fix listed
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 9.0.0.M1; fixed in 9.0.110
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 9.0.0.M1; fixed in 9.0.110
- tomcat (Bitnami): affected all versions; fixed in 9.0.110, 10.1.47, 11.0.12
- org.apache.tomcat:tomcat (Maven): affected from 10.1.0-M1; fixed in 10.1.47
- org.apache.tomcat:tomcat (Maven): affected from 10.1.0-M1; fixed in 10.1.47
- org.apache.tomcat:tomcat (Maven): affected from 11.0.0-M1; fixed in 11.0.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-61795/ (Markdown: https://insights.sbomify.com/CVE-2025-61795/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-61795
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-61795
- OSV: https://osv.dev/vulnerability/CVE-2025-61795

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-61795/
Summaries are generated and may contain mistakes; the official description above is the record.
