CVE-2025-6186 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

High 8.7 Published Updated

Authenticated users can inject malicious HTML into work item names to achieve account takeover in GitLab.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-6186?

CVE-2025-6186 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 13 Aug 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions from 18.1 before 18.1.4, and 18.2 before 18.2.2 that could have allowed authenticated users to achieve account takeover by injecting malicious HTML into work item names.

Weakness: CWE-79

Which versions are affected by CVE-2025-6186?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 18.1.018.1.4, 18.2.2

Products include Gitlab Gitlab.

How do I fix CVE-2025-6186?

Upgrade gitlab to a fixed version for your release line: 18.1.4 or 18.2.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-6186 being exploited?

There is no known exploitation of CVE-2025-6186 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-6186, GHSA-h6qj-3xrq-vxh8, MINI-8grv-642m-4rw4, MINI-mh7j-x856-7xpv, UBUNTU-CVE-2025-6186.

Is CVE-2025-6186 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free