# CVE-2025-61913: Flowise is vulnerable to arbitrary file read, arbitrary file write

> Authenticated attackers can read and write arbitrary files via unrestricted path access in Flowise tools, potentially leading to remote command execution.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Oct 2025
- **Updated:** 14 Oct 2025
- **Also known as:** GHSA-jv9m-vf54-chjj

## What is CVE-2025-61913?

CVE-2025-61913 is a critical path traversal vulnerability in Flowiseai Flowise, published on 8 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Flowise is a drag & drop user interface to build a customized large language model flow. In versions prior to 3.0.8, WriteFileTool and ReadFileTool in Flowise do not restrict file path access, allowing authenticated attackers to exploit this vulnerability to read and write arbitrary files to any path in the file system, potentially leading to remote command execution. Flowise 3.0.8 fixes this vulnerability.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-61913?

6 open source packages ship an affected version, including Flowise, flowise and flowise-components. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Flowise` | npm | All versions | 3.0.8 |
| `Flowise` | npm | All versions | 3.0.8 |
| `flowise` | npm | All versions | 3.0.8 |
| `flowise` | npm | All versions | 3.0.8 |
| `flowise-components` | npm | All versions | 3.0.8 |
| `flowise-components` | npm | All versions | 3.0.8 |

Products: Flowiseai Flowise.

## How do I fix CVE-2025-61913?

Upgrade Flowise to 3.0.8 or later.

## Is CVE-2025-61913 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-61913 exists.

## Other vulnerabilities in Flowiseai Flowise

- [CVE-2025-71338](https://insights.sbomify.com/CVE-2025-71338/): Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API (critical 10.0)
- [CVE-2026-40933](https://insights.sbomify.com/CVE-2026-40933/): Flowise: Authenticated RCE Via MCP Adapters (critical 10.0)
- [CVE-2025-59528](https://insights.sbomify.com/CVE-2025-59528/): Flowise has Remote Code Execution vulnerability (critical 10.0)
- [CVE-2026-52098](https://insights.sbomify.com/CVE-2026-52098/): Code injection in n/a (critical 9.8)
- [CVE-2025-58434](https://insights.sbomify.com/CVE-2025-58434/): Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-61913 and fix it if it is affected.

What it is: CVE-2025-61913 is a critical path traversal vulnerability in Flowiseai Flowise, published on 8 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-61913 exists.

Affected packages and fixed versions:
- Flowise (npm): affected all versions; fixed in 3.0.8
- Flowise (npm): affected all versions; fixed in 3.0.8
- flowise (npm): affected all versions; fixed in 3.0.8
- flowise (npm): affected all versions; fixed in 3.0.8
- flowise-components (npm): affected all versions; fixed in 3.0.8
- flowise-components (npm): affected all versions; fixed in 3.0.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-61913/ (Markdown: https://insights.sbomify.com/CVE-2025-61913/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-61913
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-61913
- OSV: https://osv.dev/vulnerability/CVE-2025-61913

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-61913/
Summaries are generated and may contain mistakes; the official description above is the record.
