# CVE-2025-61915: OpenPrinting CUPS vulnerable to stack based out-of-bound write

> A user in the lpadmin group can trigger a stack-based out-of-bound write in the root-running cupsd process via the web UI, leading to code execution or privilege escalation.

- **Severity:** Medium 6.0 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Nov 2025
- **Updated:** 3 Dec 2025
- **Also known as:** ALPINE-CVE-2025-61915, AZL-71146, AZL-71152, BELL-CVE-2025-61915, CLSA-2026-1769515411, CLSA-2026-1769516003, DEBIAN-CVE-2025-61915, ECHO-f011-54e9-0443, GHSA-hxm8-vfpq-jrfc, ROOT-OS-DEBIAN-12-CVE-2025-61915, ROOT-OS-DEBIAN-13-CVE-2025-61915, SUSE-SU-2025:4289-1, UBUNTU-CVE-2025-61915, USN-7897-1

## What is CVE-2025-61915?

CVE-2025-61915 is a medium-severity memory corruption vulnerability in OpenPrinting cups, published on 29 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. Prior to version 2.4.15, a user in the lpadmin group can use the cups web ui to change the config and insert a malicious line. Then the cupsd process which runs as root will parse the new config and cause an out-of-bound write. This issue has been patched in version 2.4.15.

Weakness: CWE-129 (Improper Validation of Array Index), CWE-124 (Buffer Underwrite)

## Which versions are affected by CVE-2025-61915?

It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cups` | SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 1.7.5-20.57.1 |

Products: Openprinting Cups.

## How do I fix CVE-2025-61915?

Upgrade to a fixed version.

## Is CVE-2025-61915 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-61915 exists.

## Other vulnerabilities in OpenPrinting cups

- [CVE-2025-58060](https://insights.sbomify.com/CVE-2025-58060/): cups has Authentication bypass with AuthType Negotiate (high 8.0)
- [CVE-2026-34978](https://insights.sbomify.com/CVE-2026-34978/): Path traversal in cups (medium 6.5)
- [CVE-2025-58364](https://insights.sbomify.com/CVE-2025-58364/): cups: Remote DoS via null dereference (medium 6.5)
- [CVE-2026-34980](https://insights.sbomify.com/CVE-2026-34980/): OpenPrinting CUPS: Shared PostScript queue lets anonymous Print-Job requests reach `lp` code execution over the network (medium 6.1)
- [CVE-2026-55480](https://insights.sbomify.com/CVE-2026-55480/): CUPS copy_model() creates a predictable PPD tempfile without O_EXCL/O_NOFOLLOW (symlink TOCTOU, lp → root) (medium 5.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-61915 and fix it if it is affected.

What it is: CVE-2025-61915 is a medium-severity memory corruption vulnerability in OpenPrinting cups, published on 29 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-61915 exists.

Affected product: OpenPrinting cups. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-61915/ (Markdown: https://insights.sbomify.com/CVE-2025-61915/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-61915
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-61915
- OSV: https://osv.dev/vulnerability/CVE-2025-61915

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-61915/
Summaries are generated and may contain mistakes; the official description above is the record.
