CVE-2025-61916 Spinnaker vulnerable to SSRF due to improper restrictions on http from user input
Attackers can exploit improper URL restrictions in Spinnaker to perform server-side request forgery, potentially exposing internal data and credentials.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-61916?
CVE-2025-61916 is a high-severity server-side request forgery vulnerability in spinnaker, published on 5 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Spinnaker is an open source, multi-cloud continuous delivery platform. Versions prior to 2025.1.6, 2025.2.3, and 2025.3.0 are vulnerable to server-side request forgery. The primary impact is allowing users to fetch data from a remote URL. This data can be then injected into spinnaker pipelines via helm or other methods to extract things LIKE idmsv1 authentication data. This also includes calling internal spinnaker API's via a get and similar endpoints. Further, depending upon the artifact in question, auth data may be exposed to arbitrary endpoints (e.g. GitHub auth headers) leading to credentials exposure. To trigger this, a spinnaker installation MUST have two things. The first is an artifact enabled that allows user input. This includes GitHub file artifacts, BitBucket, GitLab, HTTP artifacts and similar artifact providers. JUST enabling the http artifact provider will add a "no-auth" http provider that could be used to extract link local data (e.g. AWS Metadata information). The second is a system that can consume the output of these artifacts. e.g. Rosco helm can use this to fetch values data. K8s account manifests if the API returns JSON can be used to inject that data into the pipeline itself though the pipeline would fail. This vulnerability is fixed in versions 2025.1.6, 2025.2.3, and 2025.3.0. As a workaround, disable HTTP account types that allow user input of a given URL. This is probably not feasible in most cases. Git, Docker and other artifact account types with explicit URL configurations bypass this limitation and should be safe as they limit artifact URL loading. Alternatively, use one of the various vendors which provide OPA policies to restrict pipelines from accessing or saving a pipeline with invalid URLs.
Which versions are affected by CVE-2025-61916?
4 open source packages ship an affected version, including io.spinnaker.clouddriver:clouddriver-artifacts. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
io.spinnaker.clouddriver:clouddriver-artifacts Maven | All versions | 2025.1.6 |
io.spinnaker.clouddriver:clouddriver-artifacts Maven | All versions | 2025.1.6 |
io.spinnaker.clouddriver:clouddriver-artifacts Maven | From 2025.2.0 | 2025.2.3 |
io.spinnaker.clouddriver:clouddriver-artifacts Maven | From 2025.2.0 | 2025.2.3 |
Products include Linuxfoundation Spinnaker.
How do I fix CVE-2025-61916?
Upgrade io.spinnaker.clouddriver:clouddriver-artifacts to a fixed version for your release line: 2025.1.6 or 2025.2.3.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2025-61916 being exploited?
There is no known exploitation of CVE-2025-61916 in the wild and no public exploit code.
Other vulnerabilities in spinnaker
- CVE-2026-32604 Spinnaker: RCE when using gitrepo artifact types due to improper sanitization of user input on branch and paths
- CVE-2026-32613 Spinnaker vulnerable to RCE via expression parsing due to unrestricted context handling
- CVE-2021-43832 Improper Access Control in spinnaker
- CVE-2026-44795 Spinnaker: Non-safe yaml deserialization allowing RCE when using specific types
- CVE-2020-9301 Code injection in Netflix Spinnaker
Sources
Also known as GHSA-vrjc-q2fh-6x9h.