# CVE-2025-61916: Spinnaker vulnerable to SSRF due to improper restrictions on http from user input

> Attackers can exploit improper URL restrictions in Spinnaker to perform server-side request forgery, potentially exposing internal data and credentials.

- **Severity:** High 7.9 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jan 2026
- **Updated:** 5 Jan 2026
- **Also known as:** GHSA-vrjc-q2fh-6x9h

## What is CVE-2025-61916?

CVE-2025-61916 is a high-severity server-side request forgery vulnerability in spinnaker, published on 5 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Spinnaker is an open source, multi-cloud continuous delivery platform. Versions prior to 2025.1.6, 2025.2.3, and 2025.3.0 are vulnerable to server-side request forgery. The primary impact is allowing users to fetch data from a remote URL. This data can be then injected into spinnaker pipelines via helm or other methods to extract things LIKE idmsv1 authentication data. This also includes calling internal spinnaker API's via a get and similar endpoints. Further, depending upon the artifact in question, auth data may be exposed to arbitrary endpoints (e.g. GitHub auth headers) leading to credentials exposure. To trigger this, a spinnaker installation MUST have two things. The first is an artifact enabled that allows user input. This includes GitHub file artifacts, BitBucket, GitLab, HTTP artifacts and similar artifact providers. JUST enabling the http artifact provider will add a "no-auth" http provider that could be used to extract link local data (e.g. AWS Metadata information). The second is a system that can consume the output of these artifacts. e.g. Rosco helm can use this to fetch values data. K8s account manifests if the API returns JSON can be used to inject that data into the pipeline itself though the pipeline would fail. This vulnerability is fixed in versions 2025.1.6, 2025.2.3, and 2025.3.0. As a workaround, disable HTTP account types that allow user input of a given URL. This is probably not feasible in most cases. Git, Docker and other artifact account types with explicit URL configurations bypass this limitation and should be safe as they limit artifact URL loading. Alternatively, use one of the various vendors which provide OPA policies to restrict pipelines from accessing or saving a pipeline with invalid URLs.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-523 (Unprotected Transport of Credentials), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-61916?

4 open source packages ship an affected version, including io.spinnaker.clouddriver:clouddriver-artifacts. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.spinnaker.clouddriver:clouddriver-artifacts` | Maven | All versions | 2025.1.6 |
| `io.spinnaker.clouddriver:clouddriver-artifacts` | Maven | All versions | 2025.1.6 |
| `io.spinnaker.clouddriver:clouddriver-artifacts` | Maven | From 2025.2.0 | 2025.2.3 |
| `io.spinnaker.clouddriver:clouddriver-artifacts` | Maven | From 2025.2.0 | 2025.2.3 |

Products: Linuxfoundation Spinnaker.

## How do I fix CVE-2025-61916?

Upgrade io.spinnaker.clouddriver:clouddriver-artifacts to a fixed version for your release line: 2025.1.6 or 2025.2.3.

## Is CVE-2025-61916 being exploited?

There is no known exploitation of CVE-2025-61916 in the wild and no public exploit code.

## Other vulnerabilities in spinnaker

- [CVE-2026-32604](https://insights.sbomify.com/CVE-2026-32604/): Spinnaker: RCE when using gitrepo artifact types due to improper sanitization of user input on branch and paths (critical 10.0)
- [CVE-2026-32613](https://insights.sbomify.com/CVE-2026-32613/): Spinnaker vulnerable to RCE via expression parsing due to unrestricted context handling (critical 10.0)
- [CVE-2021-43832](https://insights.sbomify.com/CVE-2021-43832/): Improper Access Control in spinnaker (critical 10.0)
- [CVE-2026-44795](https://insights.sbomify.com/CVE-2026-44795/): Spinnaker: Non-safe yaml deserialization allowing RCE when using specific types (high 8.8)
- [CVE-2020-9301](https://insights.sbomify.com/CVE-2020-9301/): Code injection in Netflix Spinnaker (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-61916 and fix it if it is affected.

What it is: CVE-2025-61916 is a high-severity server-side request forgery vulnerability in spinnaker, published on 5 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-61916 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.spinnaker.clouddriver:clouddriver-artifacts (Maven): affected all versions; fixed in 2025.1.6
- io.spinnaker.clouddriver:clouddriver-artifacts (Maven): affected all versions; fixed in 2025.1.6
- io.spinnaker.clouddriver:clouddriver-artifacts (Maven): affected from 2025.2.0; fixed in 2025.2.3
- io.spinnaker.clouddriver:clouddriver-artifacts (Maven): affected from 2025.2.0; fixed in 2025.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-61916/ (Markdown: https://insights.sbomify.com/CVE-2025-61916/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-61916
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-61916
- OSV: https://osv.dev/vulnerability/CVE-2025-61916

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-61916/
Summaries are generated and may contain mistakes; the official description above is the record.
