# CVE-2025-61917: n8n Unsafe Buffer Allocation Allows In-Process Memory Disclosure in Task Runner

> Untrusted code in n8n task runner can access uninitialized memory, potentially exposing secrets and tokens from the same process.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Feb 2026
- **Updated:** 5 Feb 2026
- **Also known as:** GHSA-49mx-fj45-q3p6

## What is CVE-2025-61917?

CVE-2025-61917 is a high-severity vulnerability in N8n N8n, published on 4 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

n8n is an open source workflow automation platform. From version 1.65.0 to before 1.114.3, the use of Buffer.allocUnsafe() and Buffer.allocUnsafeSlow() in the task runner allowed untrusted code to allocate uninitialized memory. Such uninitialized buffers could contain residual data from within the same Node.js process (for example, data from prior requests, tasks, secrets, or tokens), resulting in potential information disclosure. This issue has been patched in version 1.114.3.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-61917?

2 open source packages ship an affected version, including n8n. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `n8n` | npm | From 1.65.0 | 1.114.3 |
| `n8n` | npm | From 1.65.0 | 1.114.3 |

Products: N8n N8n.

## How do I fix CVE-2025-61917?

Upgrade n8n to 1.114.3 or later.

## Is CVE-2025-61917 being exploited?

There is no known exploitation of CVE-2025-61917 in the wild and no public exploit code.

## Other vulnerabilities in N8n N8n

- [CVE-2025-68613](https://insights.sbomify.com/CVE-2025-68613/): n8n Improper Control of Dynamically-Managed Code Resources (critical 10.0, exploited in the wild)
- [CVE-2026-21877](https://insights.sbomify.com/CVE-2026-21877/): n8n is vulnerable to Remote Code Execution via Arbitrary File Write (critical 10.0)
- [CVE-2026-21858](https://insights.sbomify.com/CVE-2026-21858/): n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling (critical 10.0)
- [CVE-2026-1470](https://insights.sbomify.com/CVE-2026-1470/): n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution (critical 9.9)
- [CVE-2025-68668](https://insights.sbomify.com/CVE-2025-68668/): n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-61917 and fix it if it is affected.

What it is: CVE-2025-61917 is a high-severity vulnerability in N8n N8n, published on 4 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-61917 in the wild and no public exploit code.

Affected packages and fixed versions:
- n8n (npm): affected from 1.65.0; fixed in 1.114.3
- n8n (npm): affected from 1.65.0; fixed in 1.114.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-61917/ (Markdown: https://insights.sbomify.com/CVE-2025-61917/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-61917
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-61917
- OSV: https://osv.dev/vulnerability/CVE-2025-61917

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-61917/
Summaries are generated and may contain mistakes; the official description above is the record.
