CVE-2025-61919 Rack is vulnerable to a memory-exhaustion DoS through unbounded URL-encoded body parsing
Attackers can cause denial of service by sending large URL-encoded request bodies that exhaust memory in Rack applications.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-61919?
CVE-2025-61919 is a high-severity denial of service vulnerability in rack, published on 10 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Rack is a modular Ruby web server interface. Prior to versions 2.2.20, 3.1.18, and 3.2.3, `Rack::Request#POST` reads the entire request body into memory for `Content-Type: application/x-www-form-urlencoded`, calling `rack.input.read(nil)` without enforcing a length or cap. Large request bodies can therefore be buffered completely into process memory before parsing, leading to denial of service (DoS) through memory exhaustion. Users should upgrade to Rack version 2.2.20, 3.1.18, or 3.2.3, anu of which enforces form parameter limits using `query_parser.bytesize_limit`, preventing unbounded reads of `application/x-www-form-urlencoded` bodies. Additionally, enforce strict maximum body size at the proxy or web server layer (e.g., Nginx `client_max_body_size`, Apache `LimitRequestBody`).
Weakness: CWE-400
Which versions are affected by CVE-2025-61919?
6 open source packages ship an affected version, including rack. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
rack RubyGems | All versions | 2.2.20 |
rack RubyGems | All versions | 2.2.20 |
rack RubyGems | From 3.0 | 3.1.18 |
rack RubyGems | From 3.0 | 3.1.18 |
rack RubyGems | From 3.2 | 3.2.3 |
rack RubyGems | From 3.2 | 3.2.3 |
Linux distribution packages (1)
rubygem-rack-2.2 openSUSE:Tumbleweed | All versions | 2.2.20-1.1 |
Products include Rack Rack.
How do I fix CVE-2025-61919?
Upgrade rack to a fixed version for your release line: 2.2.20, 3.1.18 or 3.2.3.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-61919 being exploited?
There is no known exploitation of CVE-2025-61919 in the wild and no public exploit code.
Other vulnerabilities in rack
- CVE-2026-34785 Rack: Local file inclusion in `Rack::Static` via URL Prefix Matching
- CVE-2026-34827 Rack: Algorithmic-Complexity DoS in Rack::Multipart::Parser
- CVE-2026-34829 Rack: Denial of Service via Unbounded Multipart File Upload Without Content-Length
- CVE-2026-22860 Rack has a Directory Traversal via Rack:Directory
- CVE-2025-61770 Rack's unbounded multipart preamble buffering enables DoS (memory exhaustion)
Sources
Also known as CLEANSTART-2026-QV86619, CLEANSTART-2026-RO71198, CLSA-2026-1792144466, DEBIAN-CVE-2025-61919, GHSA-6xw4-3v39-52mm, MINI-3fw6-qqrc-g7qf and 15 more.