# CVE-2025-61919: Rack is vulnerable to a memory-exhaustion DoS through unbounded URL-encoded body parsing

> Attackers can cause denial of service by sending large URL-encoded request bodies that exhaust memory in Rack applications.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Oct 2025
- **Updated:** 10 Oct 2025
- **Also known as:** CLEANSTART-2026-QV86619, CLEANSTART-2026-RO71198, CLSA-2026-1792144466, DEBIAN-CVE-2025-61919, GHSA-6xw4-3v39-52mm, MINI-3fw6-qqrc-g7qf, MINI-833x-5hmg-wrh4, MINI-8xqc-8fg4-ccfq, MINI-9666-q4h4-9mxj, MINI-f8g5-8792-8xpj, MINI-gv4c-cphr-6hfj, MINI-hvfp-9w4r-3cc5, MINI-jpf8-p6mx-2j86, MINI-mc2q-hc4m-rfqw, MINI-p7w5-j953-gp8c, MINI-r5gg-9mf9-94vv, MINI-rg5x-gfh4-4c2m, MINI-v2c9-cq35-gfg4, MINI-xqpv-cjvc-48w4, UBUNTU-CVE-2025-61919, openSUSE-SU-2025:15642-1

## What is CVE-2025-61919?

CVE-2025-61919 is a high-severity denial of service vulnerability in rack, published on 10 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Rack is a modular Ruby web server interface. Prior to versions 2.2.20, 3.1.18, and 3.2.3, `Rack::Request#POST` reads the entire request body into memory for `Content-Type: application/x-www-form-urlencoded`, calling `rack.input.read(nil)` without enforcing a length or cap. Large request bodies can therefore be buffered completely into process memory before parsing, leading to denial of service (DoS) through memory exhaustion. Users should upgrade to Rack version 2.2.20, 3.1.18, or 3.2.3, anu of which enforces form parameter limits using `query_parser.bytesize_limit`, preventing unbounded reads of `application/x-www-form-urlencoded` bodies. Additionally, enforce strict maximum body size at the proxy or web server layer (e.g., Nginx `client_max_body_size`, Apache `LimitRequestBody`).

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2025-61919?

6 open source packages ship an affected version, including rack. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rack` | RubyGems | All versions | 2.2.20 |
| `rack` | RubyGems | All versions | 2.2.20 |
| `rack` | RubyGems | From 3.0 | 3.1.18 |
| `rack` | RubyGems | From 3.0 | 3.1.18 |
| `rack` | RubyGems | From 3.2 | 3.2.3 |
| `rack` | RubyGems | From 3.2 | 3.2.3 |
| `rubygem-rack-2.2` | openSUSE:Tumbleweed | All versions | 2.2.20-1.1 |

Products: Rack Rack.

## How do I fix CVE-2025-61919?

Upgrade rack to a fixed version for your release line: 2.2.20, 3.1.18 or 3.2.3.

## Is CVE-2025-61919 being exploited?

There is no known exploitation of CVE-2025-61919 in the wild and no public exploit code.

## Other vulnerabilities in rack

- [CVE-2026-34785](https://insights.sbomify.com/CVE-2026-34785/): Rack: Local file inclusion in `Rack::Static` via URL Prefix Matching (high 7.5)
- [CVE-2026-34827](https://insights.sbomify.com/CVE-2026-34827/): Rack: Algorithmic-Complexity DoS in Rack::Multipart::Parser (high 7.5)
- [CVE-2026-34829](https://insights.sbomify.com/CVE-2026-34829/): Rack: Denial of Service via Unbounded Multipart File Upload Without Content-Length (high 7.5)
- [CVE-2026-22860](https://insights.sbomify.com/CVE-2026-22860/): Rack has a Directory Traversal via Rack:Directory (high 7.5)
- [CVE-2025-61770](https://insights.sbomify.com/CVE-2025-61770/): Rack's unbounded multipart preamble buffering enables DoS (memory exhaustion) (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-61919 and fix it if it is affected.

What it is: CVE-2025-61919 is a high-severity denial of service vulnerability in rack, published on 10 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-61919 in the wild and no public exploit code.

Affected packages and fixed versions:
- rack (RubyGems): affected all versions; fixed in 2.2.20
- rack (RubyGems): affected all versions; fixed in 2.2.20
- rack (RubyGems): affected from 3.0; fixed in 3.1.18
- rack (RubyGems): affected from 3.0; fixed in 3.1.18
- rack (RubyGems): affected from 3.2; fixed in 3.2.3
- rack (RubyGems): affected from 3.2; fixed in 3.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-61919/ (Markdown: https://insights.sbomify.com/CVE-2025-61919/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-61919
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-61919
- OSV: https://osv.dev/vulnerability/CVE-2025-61919

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-61919/
Summaries are generated and may contain mistakes; the official description above is the record.
