# CVE-2025-61920: Authlib is vulnerable to Denial of Service via Oversized JOSE Segments

> Remote attackers can cause denial of service in Authlib by sending oversized JOSE segments, exhausting CPU and memory resources.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Oct 2025
- **Updated:** 3 Nov 2025
- **Also known as:** DEBIAN-CVE-2025-61920, ECHO-9171-850d-97d8, GHSA-pq5p-34cr-23v9, PYSEC-2026-1203, ROOT-APP-PYPI-CVE-2025-61920, SUSE-SU-2025:3754-1, UBUNTU-CVE-2025-61920, openSUSE-SU-2025:15629-1

## What is CVE-2025-61920?

CVE-2025-61920 is a high-severity denial of service vulnerability in authlib, published on 10 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Authlib is a Python library which builds OAuth and OpenID Connect servers. Prior to version 1.6.5, Authlib’s JOSE implementation accepts unbounded JWS/JWT header and signature segments. A remote attacker can craft a token whose base64url‑encoded header or signature spans hundreds of megabytes. During verification, Authlib decodes and parses the full input before it is rejected, driving CPU and memory consumption to hostile levels and enabling denial of service. Version 1.6.5 patches the issue. Some temporary workarounds are available. Enforce input size limits before handing tokens to Authlib and/or use application-level throttling to reduce amplification risk.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-61920?

3 open source packages ship an affected version, including authlib. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `authlib` | PyPI | All versions | 1.6.5 |
| `authlib` | PyPI | All versions | 1.6.5 |
| `authlib` | PyPI | All versions | 1.6.5 |
| `python-Authlib` | SUSE:Linux Enterprise Module for Python 3 15 SP6 | All versions | 1.3.1-150600.3.6.1 |
| `python-Authlib` | SUSE:Linux Enterprise Module for Python 3 15 SP7 | All versions | 1.3.1-150600.3.6.1 |
| `python-Authlib` | openSUSE:Leap 15.6 | All versions | 1.3.1-150600.3.6.1 |
| `python-Authlib` | openSUSE:Tumbleweed | All versions | 1.6.5-1.1 |

Products: Authlib Authlib.

## How do I fix CVE-2025-61920?

Upgrade authlib to 1.6.5 or later.

## Is CVE-2025-61920 being exploited?

There is no known exploitation of CVE-2025-61920 in the wild and no public exploit code.

## Other vulnerabilities in authlib

- [CVE-2026-27962](https://insights.sbomify.com/CVE-2026-27962/): Authlib JWS JWK Header Injection: Signature Verification Bypass (critical 9.1)
- [CVE-2026-28490](https://insights.sbomify.com/CVE-2026-28490/): Authlib Vulnerable to JWE RSA1_5 Bleichenbacher Padding Oracle (high 8.3)
- [CVE-2026-28498](https://insights.sbomify.com/CVE-2026-28498/): Authlib: Fail-Open Cryptographic Verification in OIDC Hash Binding (high 8.2)
- [CVE-2026-28802](https://insights.sbomify.com/CVE-2026-28802/): Authlib: Setting `alg: none` and a blank signature appears to bypass signature verification (high 7.7)
- [CVE-2025-59420](https://insights.sbomify.com/CVE-2025-59420/): Authlib: JWS/JWT accepts unknown crit headers (RFC violation → possible authz bypass) (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-61920 and fix it if it is affected.

What it is: CVE-2025-61920 is a high-severity denial of service vulnerability in authlib, published on 10 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-61920 in the wild and no public exploit code.

Affected packages and fixed versions:
- authlib (PyPI): affected all versions; fixed in 1.6.5
- authlib (PyPI): affected all versions; fixed in 1.6.5
- authlib (PyPI): affected all versions; fixed in 1.6.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-61920/ (Markdown: https://insights.sbomify.com/CVE-2025-61920/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-61920
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-61920
- OSV: https://osv.dev/vulnerability/CVE-2025-61920

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-61920/
Summaries are generated and may contain mistakes; the official description above is the record.
